diff mbox series

[bug#53822] Add python-aiopg package.

Message ID 20220206144723.1755119-1-contact@phfrohring.com
State Accepted
Headers show
Series [bug#53822] Add python-aiopg package. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Pierre-Henry Fröhring Feb. 6, 2022, 2:47 p.m. UTC
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

M Feb. 6, 2022, 2:54 p.m. UTC | #1
Pierre-Henry Fröhring schreef op zo 06-02-2022 om 15:47 [+0100]:
> +    (native-inputs (list python-sqlalchemy))
> +    (propagated-inputs (list python-async-timeout python-psycopg2-binary))
> +    (home-page "https://aiopg.readthedocs.io")
> +    (synopsis "Postgres integration with asyncio")
> +    (description
> +     "aiopg is a library for accessing a PostgreSQL
> +database from the asyncio (PEP-3156/tulip) framework.  It wraps
> +asynchronous features of the Psycopg database driver.")

Given that python-aiopg is a SQL library, python-sqlalchemy looks like
a (runtime) dependency of 'python-aiopg' to me.  Or perhaps it's only
for tests, then putting it in native-inputs is correct.

Greetings,
MMaxime.
Ludovic Courtès March 24, 2022, 10:26 p.m. UTC | #2
Pierre-Henry Fröhring <contact@phfrohring.com> skribis:

> +(define-public python-aiopg

Added a commit log and applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7c1b5e8ed3..a28a050480 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28931,3 +28931,24 @@  (define-public python-types-dataclasses
      "This packages provides a collection of library stubs for Python, with
 static types.")
     (license license:asl2.0)))
+
+(define-public python-aiopg
+  (package
+    (name "python-aiopg")
+    (version "1.3.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "aiopg" version))
+              (sha256
+               (base32
+                "1mwmypsfzh8adjbyvf7kqv9h3k1kf5ykhi1g3ahw4wqdxaj6nz2l"))))
+    (build-system python-build-system)
+    (native-inputs (list python-sqlalchemy))
+    (propagated-inputs (list python-async-timeout python-psycopg2-binary))
+    (home-page "https://aiopg.readthedocs.io")
+    (synopsis "Postgres integration with asyncio")
+    (description
+     "aiopg is a library for accessing a PostgreSQL
+database from the asyncio (PEP-3156/tulip) framework.  It wraps
+asynchronous features of the Psycopg database driver.")
+    (license license:bsd-3)))