diff mbox series

[bug#53609,v2,3/4] gnu: Add glibc-2.2.5.

Message ID 20220205000823.2680-3-rekado@elephly.net
State Accepted
Headers show
Series [bug#53609,v2,1/4] gnu: Add perl-5.14. | expand

Commit Message

Ricardo Wurmus Feb. 5, 2022, 12:08 a.m. UTC
* gnu/packages/commencement.scm (glibc-2.2.5): New variable.
---
 gnu/packages/commencement.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

M Feb. 5, 2022, 2:44 p.m. UTC | #1
Ricardo Wurmus schreef op za 05-02-2022 om 01:08 [+0100]:
> +      ((#:configure-flags flags '())
> +       #~(let ((out (assoc-ref %outputs "out"))

(assoc-ref %outputs "out") -> #$output

> +               (headers (assoc-ref %build-inputs "kernel-headers")))
> +           `("--enable-shared"
> +             "--enable-static"
> +             "--disable-sanity-checks"
> +             "--build=i686-unknown-linux-gnu"
> +             "--host=i686-unknown-linux-gnu"

Given that it's always compiled for i686-linux, even on x86_64, should
#:system "i686-linux" be set be added to 'arguments', such that glibc-
2.2.5 only needs to be compiled once?  Likewise for the
'glibc-mesboot0' package (on core-updates).

Greetings,
Maxime
diff mbox series

Patch

diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 6bbadff796..4f10b22e78 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3471,6 +3471,30 @@  (define glibc-final
        ,@(package-outputs glibc-final-with-bootstrap-bash))
       ,@(package-arguments glibc-final-with-bootstrap-bash)))))
 
+(define glibc-2.2.5
+  (package/inherit
+   glibc-mesboot0
+   (arguments
+    (substitute-keyword-arguments (package-arguments glibc-mesboot0)
+      ((#:configure-flags flags '())
+       #~(let ((out (assoc-ref %outputs "out"))
+               (headers (assoc-ref %build-inputs "kernel-headers")))
+           `("--enable-shared"
+             "--enable-static"
+             "--disable-sanity-checks"
+             "--build=i686-unknown-linux-gnu"
+             "--host=i686-unknown-linux-gnu"
+             ,(string-append "--with-headers=" headers "/include")
+             "--enable-static-nss"
+             "--without-__thread"
+             "--without-cvs"
+             "--without-gd"
+             "--without-tls"
+             ,(string-append "--prefix=" out))))))
+   (propagated-inputs `(("kernel-headers" ,linux-libre-headers)))
+   (native-inputs
+    (alist-delete "kernel-headers" (%boot-mesboot1-inputs)))))
+
 (define/system-dependent gcc-boot0-wrapped
   ;; Make the cross-tools GCC-BOOT0 and BINUTILS-BOOT0 available under the
   ;; non-cross names.