diff mbox series

[bug#53772,v2] gnu: Add emacs-blacken.

Message ID 20220204090643.23354-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#53772,v2] gnu: Add emacs-blacken. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Feb. 4, 2022, 9:06 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-blacken): New variable.
---

Hi Liliana,

Thanks for the review and the suggestions.

Here is version two.

all best,

jgart

 gnu/packages/emacs-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Liliana Marie Prikler Feb. 4, 2022, 7:51 p.m. UTC | #1
Am Freitag, dem 04.02.2022 um 04:06 -0500 schrieb jgart:
> * gnu/packages/emacs-xyz.scm (emacs-blacken): New variable.
> ---
> 
> Hi Liliana,
> 
> Thanks for the review and the suggestions.
> 
> Here is version two.
> 
> all best,
> 
> jgart
LGTM, pushed
jgart Feb. 4, 2022, 8:36 p.m. UTC | #2
On Fri, 04 Feb 2022 20:51:55 +0100 Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:
> LGTM, pushed

THNX!
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 521d003a6b..444b761116 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29822,6 +29822,39 @@  (define-public emacs-multitran
 to the @url{https://multitran.com} online dictionary.")
     (license license:gpl3+)))
 
+(define-public emacs-blacken
+  (package
+    (name "emacs-blacken")
+    (version "0.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/pythonic-emacs/blacken")
+         (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0pf9yllx0h78m925sdrg6hbv54ky2pi7cpkdsnx891qjsahvjnpy"))))
+    (build-system emacs-build-system)
+    (inputs
+      (list python-black))
+    (arguments
+      `(#:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'patch-python-black
+             (lambda* (#:key inputs #:allow-other-keys)
+               (make-file-writable "blacken.el")
+               (emacs-substitute-variables "blacken.el"
+                 ("blacken-executable"
+                   (search-input-file inputs "/bin/black"))))))))
+    (home-page "https://github.com/pythonic-emacs/blacken")
+    (synopsis "Python Black for Emacs")
+    (description
+"Use the @command{python} @command{black} package to reformat
+@command{python} buffers.")
+    (license license:gpl3)))
+
 (define-public emacs-kibit-helper
   (package
     (name "emacs-kibit-helper")