diff mbox series

[bug#53738] gnu: nyxt: Add missing input.

Message ID 20220202220516.24153-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#53738] gnu: nyxt: Add missing input. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Feb. 2, 2022, 10:05 p.m. UTC
* gnu/packages/web-browsers.scm (nyxt)[inputs]: Add sbcl-cl-gopher.
---
 gnu/packages/web-browsers.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

Guillaume Le Vaillant Feb. 3, 2022, 9:49 a.m. UTC | #1
jgart via Guix-patches via <guix-patches@gnu.org> skribis:

> * gnu/packages/web-browsers.scm (nyxt)[inputs]: Add sbcl-cl-gopher.
> ---
>  gnu/packages/web-browsers.scm | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
> index c49e3ceac5..1aec6d6adc 100644
> --- a/gnu/packages/web-browsers.scm
> +++ b/gnu/packages/web-browsers.scm
> @@ -639,6 +639,7 @@ (define-public nyxt
>         ("cl-containers" ,sbcl-cl-containers)
>         ("cl-css" ,sbcl-cl-css)
>         ("cl-custom-hash-table" ,sbcl-custom-hash-table)
> +       ("cl-gopher" ,sbcl-cl-gopher)
>         ("cl-html-diff" ,sbcl-cl-html-diff)
>         ("cl-json" ,sbcl-cl-json)
>         ("cl-ppcre" ,sbcl-cl-ppcre)

Hi,

What issue is solved by adding cl-gopher to inputs?

As far as I can see the source code for Nyxt 2.2.4 doesn't contain any
reference to cl-gopher, so just adding it to inputs will not change the
produced nyxt program.

According to the upstream repository, support for Gopher and Gemini will
be in Nyxt 3.0.0, which has not been released yet.
jgart Feb. 3, 2022, 9:37 p.m. UTC | #2
On Thu, 03 Feb 2022 09:49:26 +0000 Guillaume Le Vaillant <glv@posteo.net> wrote:
> jgart via Guix-patches via <guix-patches@gnu.org> skribis:
> 
> > * gnu/packages/web-browsers.scm (nyxt)[inputs]: Add sbcl-cl-gopher.
> > ---
> >  gnu/packages/web-browsers.scm | 1 +
> >  1 file changed, 1 insertion(+)
> >
> > diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
> > index c49e3ceac5..1aec6d6adc 100644
> > --- a/gnu/packages/web-browsers.scm
> > +++ b/gnu/packages/web-browsers.scm
> > @@ -639,6 +639,7 @@ (define-public nyxt
> >         ("cl-containers" ,sbcl-cl-containers)
> >         ("cl-css" ,sbcl-cl-css)
> >         ("cl-custom-hash-table" ,sbcl-custom-hash-table)
> > +       ("cl-gopher" ,sbcl-cl-gopher)
> >         ("cl-html-diff" ,sbcl-cl-html-diff)
> >         ("cl-json" ,sbcl-cl-json)
> >         ("cl-ppcre" ,sbcl-cl-ppcre)
> 
> Hi,
> 
> What issue is solved by adding cl-gopher to inputs?
> 
> As far as I can see the source code for Nyxt 2.2.4 doesn't contain any
> reference to cl-gopher, so just adding it to inputs will not change the
> produced nyxt program.
> 
> According to the upstream repository, support for Gopher and Gemini will
> be in Nyxt 3.0.0, which has not been released yet.

Ah ok. I was accidently reading the master branch latest commit instead
of version 2.2.4.

https://github.com/atlas-engineer/nyxt/blob/16a89132fdbf56c713033edcc2d4611f06199f3c/source/mode/small-web.lisp#L18

Sorry, yes, let's wait.

all best,

jgart
Guillaume Le Vaillant Feb. 3, 2022, 10:20 p.m. UTC | #3
jgart <jgart@dismail.de> skribis:

> Ah ok. I was accidently reading the master branch latest commit instead
> of version 2.2.4.
>
> https://github.com/atlas-engineer/nyxt/blob/16a89132fdbf56c713033edcc2d4611f06199f3c/source/mode/small-web.lisp#L18
>
> Sorry, yes, let's wait.
>
> all best,
>
> jgart

Thanks for confirming.
Closing for now.
diff mbox series

Patch

diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index c49e3ceac5..1aec6d6adc 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -639,6 +639,7 @@  (define-public nyxt
        ("cl-containers" ,sbcl-cl-containers)
        ("cl-css" ,sbcl-cl-css)
        ("cl-custom-hash-table" ,sbcl-custom-hash-table)
+       ("cl-gopher" ,sbcl-cl-gopher)
        ("cl-html-diff" ,sbcl-cl-html-diff)
        ("cl-json" ,sbcl-cl-json)
        ("cl-ppcre" ,sbcl-cl-ppcre)