diff mbox series

[bug#53725] gnu: mlt: Wrap LADSPA_PATH and FREI0R_PATH.

Message ID 20220202155221.289085-1-monego@posteo.net
State Accepted
Headers show
Series [bug#53725] gnu: mlt: Wrap LADSPA_PATH and FREI0R_PATH. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Feb. 2, 2022, 3:52 p.m. UTC
* gnu/packages/video.scm (mlt)[arguments]: Use gexps. Add 'wrap-executable
phase.
[inputs]: Add bash-minimal.
---
Sending to list for comments about the symlink workaround. The linter also complains about alsa-plugins input, but I don't know what to do about it.

 gnu/packages/video.scm | 34 +++++++++++++++++++++++++---------
 1 file changed, 25 insertions(+), 9 deletions(-)

Comments

Ludovic Courtès March 3, 2022, 10:46 p.m. UTC | #1
Hi Vinicius,

Vinicius Monego <monego@posteo.net> skribis:

> * gnu/packages/video.scm (mlt)[arguments]: Use gexps. Add 'wrap-executable
> phase.
> [inputs]: Add bash-minimal.

LGTM, thanks!

Ludo’.
Vinicius Monego March 4, 2022, 1:34 a.m. UTC | #2
On 03/03/2022 7:46 PM, Ludovic Courtès wrote:
> Hi Vinicius,
>
> Vinicius Monego <monego@posteo.net> skribis:
>
>> * gnu/packages/video.scm (mlt)[arguments]: Use gexps. Add 'wrap-executable
>> phase.
>> [inputs]: Add bash-minimal.
> LGTM, thanks!
>
> Ludo’.

Thanks! Pushed this followed by an update to mlt.
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 8a903f6fe1..68cd5d3f83 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3208,18 +3208,34 @@  from sites like Twitch.tv and pipes them into a video player of choice.")
         (base32 "17d4gs46ca3n0qg6z69hl6mmllnqj2id8ccrv8fyz8c5zm55ghqm"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f ;requires "Kwalify"
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'override-LDFLAGS
-           (lambda* (#:key outputs #:allow-other-keys)
-             (setenv "LDFLAGS"
-                     (string-append
-                      "-Wl,-rpath="
-                      (assoc-ref outputs "out") "/lib")))))))
+     (list
+      #:tests? #f                       ;requires "Kwalify"
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'configure 'override-LDFLAGS
+            (lambda _
+              (setenv "LDFLAGS"
+                      (string-append "-Wl,-rpath=" #$output "/lib"))))
+          (add-after 'install 'wrap-executable
+            (lambda _
+              (let* ((frei0r #$(this-package-input "frei0r-plugins"))
+                     (ladspa #$(this-package-input "ladspa"))
+                     ;; In MLT 7, 'melt' symlinks to 'melt-7'.  Try to keep
+                     ;; compatibility with MLT 6 where it's only 'melt'.
+                     (major #$(version-major version))
+                     (exec (if (file-exists?
+                                (string-append #$output "/bin/melt-" major))
+                               (string-append "melt-" major)
+                               "melt")))
+                (wrap-program (string-append #$output "/bin/" exec)
+                  `("FREI0R_PATH" ":" =
+                    (,(string-append frei0r "/lib/frei0r-1")))
+                  `("LADSPA_PATH" ":" =
+                    (,(string-append ladspa "/lib/ladspa"))))))))))
     (inputs
      (list alsa-lib
            `(,alsa-plugins "pulseaudio")
+           bash-minimal
            ffmpeg
            fftw
            frei0r-plugins