diff mbox series

[bug#53709] gnu: js-of-ocaml: Update to 4.0.0.

Message ID 20220201193638.17121-1-pukkamustard@posteo.net
State Accepted
Headers show
Series [bug#53709] gnu: js-of-ocaml: Update to 4.0.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

pukkamustard Feb. 1, 2022, 7:36 p.m. UTC
* gnu/packages/ocaml (js-of-ocaml): Update to 4.0.0.
---
 gnu/packages/ocaml.scm | 19 ++++---------------
 1 file changed, 4 insertions(+), 15 deletions(-)

Comments

Julien Lepiller Feb. 5, 2022, 9:54 p.m. UTC | #1
Pushed to master, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 6c1ac057a4..fa6cdcb0d5 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -17,7 +17,7 @@ 
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2020, 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2020 divoplade <d@divoplade.fr>
-;;; Copyright © 2020, 2021 pukkamustard <pukkamustard@posteo.net>
+;;; Copyright © 2020, 2021, 2022 pukkamustard <pukkamustard@posteo.net>
 ;;; Copyright © 2021 aecepoglu <aecepoglu@fastmail.fm>
 ;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
@@ -7639,7 +7639,7 @@  (define-public ocaml-cohttp
 (define-public js-of-ocaml
   (package
     (name "js-of-ocaml")
-    (version "3.11.0")
+    (version "4.0.0")
     (source
      (origin
        (method git-fetch)
@@ -7648,20 +7648,9 @@  (define-public js-of-ocaml
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1x5f1ph9wgx0mgyibssssnrcwp69ihw66gzhsnz9h79czgzyjpp2"))))
+        (base32 "0iyhl9z57j53j2jvyqcwmxhbvy23l6g80aa0abmlgwam14yskspf"))))
     (build-system dune-build-system)
-    (arguments
-     `(#:test-target "."
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'fix-failing-test
-           (lambda _
-             ;; Formating difference
-             (with-output-to-file "compiler/tests-jsoo/bin/error2.expected"
-               (lambda _
-                 (format #t
-                         "Fatal error: exception Match_failure(\
-\"compiler/tests-jsoo/bin/error2.ml\", 11, 2)\n\n"))))))))
+    (arguments `(#:test-target "."))
     (propagated-inputs
      (list ocaml-ppxlib
            ocaml-uchar