diff mbox series

[bug#53642] gnu: oil: Update to 0.9.7.

Message ID 20220130210139.12096-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#53642] gnu: oil: Update to 0.9.7. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber Jan. 30, 2022, 9:01 p.m. UTC
* gnu/packages/shells.scm (oil): Update to 0.9.7.
---
 gnu/packages/shells.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès Feb. 2, 2022, 5:15 p.m. UTC | #1
Hi,

Felix Gruber <felgru@posteo.net> skribis:

> * gnu/packages/shells.scm (oil): Update to 0.9.7.

Applied, thanks!

Oil seems to include a bundled copy of CPython.  Could you check if we
can remove it and use our Python package instead?

Thanks,
Ludo’.
Felix Gruber Feb. 2, 2022, 10:17 p.m. UTC | #2
Hi Ludo’,

On 2/2/22 18:15, Ludovic Courtès wrote:
> Oil seems to include a bundled copy of CPython.  Could you check if we
> can remove it and use our Python package instead?

It seems that the CPython bundled with oil is heavily modified.
I've found this old blog post [1] that describes what was modified in 
the bundled CPython. Apparently, those parts of CPython that are not 
used by oil have been removed and the build system has been replaced by 
a custom one. This will probably make it quite complicated to replace 
the bundled CPython with ours.

[1] https://www.oilshell.org/blog/2017/05/05.html

Kind regards,
Felix
Ludovic Courtès Feb. 8, 2022, 9:55 a.m. UTC | #3
Hi,

Felix Gruber <felgru@posteo.net> skribis:

> It seems that the CPython bundled with oil is heavily modified.
> I've found this old blog post [1] that describes what was modified in
> the bundled CPython. Apparently, those parts of CPython that are not 
> used by oil have been removed and the build system has been replaced
> by a custom one. This will probably make it quite complicated to
> replace the bundled CPython with ours.
>
> [1] https://www.oilshell.org/blog/2017/05/05.html

Makes sense.  Perhaps we can add a comment explaining this, for our
future selves wondering about it.

Thanks for exlaining,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 1652848705..2e5bc3573a 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -828,14 +828,14 @@  Shell (pdksh).")
 (define-public oil
   (package
     (name "oil")
-    (version "0.9.6")
+    (version "0.9.7")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.oilshell.org/download/oil-"
                            version ".tar.gz"))
        (sha256
-        (base32 "01lmj4diqpla1gwwb1gh1shf4y74qhanpkzcsnb28458rxm1sq32"))))
+        (base32 "09ill1wks8gmixfc648wx25wx0wzlgkjj34bbpglx496i6yp81aw"))))
     (build-system gnu-build-system)
     (arguments
      (list #:strip-binaries? #f         ; strip breaks the binary