diff mbox series

[bug#53622,V2,7/8] gnu: Add emacs-apache-mode.

Message ID 20220129144810.3076-7-pinoaffe@gmail.com
State Accepted
Headers show
Series [bug#53622,V2,1/8] gnu: Add emacs-spaceline-all-the-icons. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

pinoaffe Jan. 29, 2022, 2:48 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-apache-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Nicolas Goaziou Feb. 6, 2022, 10:47 p.m. UTC | #1
Hello,

pinoaffe <pinoaffe@gmail.com> writes:

> * gnu/packages/emacs-xyz.scm (emacs-apache-mode): New variable.

Thank you. I applied this patch with the following change

> +    (license license:gpl2)))

License is gpl2+.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fad6612dd2..653061eb99 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -810,6 +810,29 @@  (define-public emacs-ox-reveal
 simple but powerful Org contents.")
     (license license:gpl3+))))
 
+(define-public emacs-apache-mode
+  (package
+    (name "emacs-apache-mode")
+    (version "2.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/emacs-php/apache-mode.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1grs2x51k8pa6sgfa82s5pwwdfv7zw46ccw0zvd2rvzbhpq21p2z"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/emacs-php/apache-mode")
+    (synopsis
+     "Syntax highlighting and indentation support for Apache config files")
+    (description
+     "This package provides @code{apache-mode}, an Emacs major mode for Apache
+configuration files which provides syntax highlighting and indentation rules.
+This mode supports Apache HTTP Server 2.4 and major modules.")
+    (license license:gpl2)))
+
 (define-public emacs-project
   (package
     (name "emacs-project")