diff mbox series

[bug#53619,1/3] gnu: linux-libre: Enable CONFIG_ZONE_DMA in all configs.

Message ID 20220129023712.4059-1-maxim.cournoyer@gmail.com
State Accepted
Headers show
Series gnu: linux-libre: Build the snd-emu10k1 module. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Maxim Cournoyer Jan. 29, 2022, 2:37 a.m. UTC
ZONE_DMA is still used by some kernel drivers such as older sound and network
cards; it was already enabled on ARM and for some i686 kernels.  Enable it
everywhere for consistency.  The change was automated with:

  $ git grep -rl CONFIG_ZONE_DMA | \
      xargs sed 's/# CONFIG_ZONE_DMA is not set/CONFIG_ZONE_DMA=y/' -i

* gnu/packages/aux-files/linux-libre/4.14-x86_64.conf: Enable CONFIG_ZONE_DMA.
* gnu/packages/aux-files/linux-libre/4.19-x86_64.conf: Likewise.
* gnu/packages/aux-files/linux-libre/4.4-x86_64.conf: Likewise.
* gnu/packages/aux-files/linux-libre/4.9-x86_64.conf: Likewise.
* gnu/packages/aux-files/linux-libre/5.10-i686.conf: Likewise.
* gnu/packages/aux-files/linux-libre/5.10-x86_64.conf: Likewise.
* gnu/packages/aux-files/linux-libre/5.15-i686.conf: Likewise.
* gnu/packages/aux-files/linux-libre/5.15-x86_64.conf: Likewise.
* gnu/packages/aux-files/linux-libre/5.16-i686.conf: Likewise.
* gnu/packages/aux-files/linux-libre/5.16-x86_64.conf: Likewise.
* gnu/packages/aux-files/linux-libre/5.4-x86_64.conf: Likewise.
---
 gnu/packages/aux-files/linux-libre/4.14-x86_64.conf | 2 +-
 gnu/packages/aux-files/linux-libre/4.19-x86_64.conf | 2 +-
 gnu/packages/aux-files/linux-libre/4.4-x86_64.conf  | 2 +-
 gnu/packages/aux-files/linux-libre/4.9-x86_64.conf  | 2 +-
 gnu/packages/aux-files/linux-libre/5.10-i686.conf   | 2 +-
 gnu/packages/aux-files/linux-libre/5.10-x86_64.conf | 2 +-
 gnu/packages/aux-files/linux-libre/5.15-i686.conf   | 2 +-
 gnu/packages/aux-files/linux-libre/5.15-x86_64.conf | 2 +-
 gnu/packages/aux-files/linux-libre/5.16-i686.conf   | 2 +-
 gnu/packages/aux-files/linux-libre/5.16-x86_64.conf | 2 +-
 gnu/packages/aux-files/linux-libre/5.4-x86_64.conf  | 2 +-
 11 files changed, 11 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/aux-files/linux-libre/4.14-x86_64.conf b/gnu/packages/aux-files/linux-libre/4.14-x86_64.conf
index db11c2f6e8..09c81b4b00 100644
--- a/gnu/packages/aux-files/linux-libre/4.14-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/4.14-x86_64.conf
@@ -454,7 +454,7 @@  CONFIG_FREEZER=y
 #
 # Processor type and features
 #
-# CONFIG_ZONE_DMA is not set
+CONFIG_ZONE_DMA=y
 CONFIG_SMP=y
 CONFIG_X86_FEATURE_NAMES=y
 CONFIG_X86_FAST_FEATURE_TESTS=y
diff --git a/gnu/packages/aux-files/linux-libre/4.19-x86_64.conf b/gnu/packages/aux-files/linux-libre/4.19-x86_64.conf
index b76fdc9148..45ab903288 100644
--- a/gnu/packages/aux-files/linux-libre/4.19-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/4.19-x86_64.conf
@@ -273,7 +273,7 @@  CONFIG_CC_HAS_SANE_STACKPROTECTOR=y
 #
 # Processor type and features
 #
-# CONFIG_ZONE_DMA is not set
+CONFIG_ZONE_DMA=y
 CONFIG_SMP=y
 CONFIG_X86_FEATURE_NAMES=y
 CONFIG_X86_X2APIC=y
diff --git a/gnu/packages/aux-files/linux-libre/4.4-x86_64.conf b/gnu/packages/aux-files/linux-libre/4.4-x86_64.conf
index 0c7852ba48..9e3f4d5e70 100644
--- a/gnu/packages/aux-files/linux-libre/4.4-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/4.4-x86_64.conf
@@ -384,7 +384,7 @@  CONFIG_FREEZER=y
 #
 # Processor type and features
 #
-# CONFIG_ZONE_DMA is not set
+CONFIG_ZONE_DMA=y
 CONFIG_SMP=y
 CONFIG_X86_FEATURE_NAMES=y
 CONFIG_X86_X2APIC=y
diff --git a/gnu/packages/aux-files/linux-libre/4.9-x86_64.conf b/gnu/packages/aux-files/linux-libre/4.9-x86_64.conf
index 6256b9f356..42edbb12a2 100644
--- a/gnu/packages/aux-files/linux-libre/4.9-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/4.9-x86_64.conf
@@ -409,7 +409,7 @@  CONFIG_FREEZER=y
 #
 # Processor type and features
 #
-# CONFIG_ZONE_DMA is not set
+CONFIG_ZONE_DMA=y
 CONFIG_SMP=y
 CONFIG_X86_FEATURE_NAMES=y
 CONFIG_X86_FAST_FEATURE_TESTS=y
diff --git a/gnu/packages/aux-files/linux-libre/5.10-i686.conf b/gnu/packages/aux-files/linux-libre/5.10-i686.conf
index d24bbbcaa2..cc4f703467 100644
--- a/gnu/packages/aux-files/linux-libre/5.10-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/5.10-i686.conf
@@ -292,7 +292,7 @@  CONFIG_CC_HAS_SANE_STACKPROTECTOR=y
 #
 # Processor type and features
 #
-# CONFIG_ZONE_DMA is not set
+CONFIG_ZONE_DMA=y
 CONFIG_SMP=y
 CONFIG_X86_FEATURE_NAMES=y
 CONFIG_X86_MPPARSE=y
diff --git a/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf b/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf
index 3a905e6286..85e5967fb1 100644
--- a/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf
@@ -308,7 +308,7 @@  CONFIG_CC_HAS_SANE_STACKPROTECTOR=y
 #
 # Processor type and features
 #
-# CONFIG_ZONE_DMA is not set
+CONFIG_ZONE_DMA=y
 CONFIG_SMP=y
 CONFIG_X86_FEATURE_NAMES=y
 CONFIG_X86_X2APIC=y
diff --git a/gnu/packages/aux-files/linux-libre/5.15-i686.conf b/gnu/packages/aux-files/linux-libre/5.15-i686.conf
index 85bd4d0ee1..c4f54ca5d3 100644
--- a/gnu/packages/aux-files/linux-libre/5.15-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/5.15-i686.conf
@@ -992,7 +992,7 @@  CONFIG_PAGE_IDLE_FLAG=y
 CONFIG_IDLE_PAGE_TRACKING=y
 CONFIG_ARCH_HAS_CACHE_LINE_SIZE=y
 CONFIG_ARCH_HAS_ZONE_DMA_SET=y
-# CONFIG_ZONE_DMA is not set
+CONFIG_ZONE_DMA=y
 CONFIG_HMM_MIRROR=y
 CONFIG_VMAP_PFN=y
 # CONFIG_PERCPU_STATS is not set
diff --git a/gnu/packages/aux-files/linux-libre/5.15-x86_64.conf b/gnu/packages/aux-files/linux-libre/5.15-x86_64.conf
index ad42192937..54f6dc375a 100644
--- a/gnu/packages/aux-files/linux-libre/5.15-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.15-x86_64.conf
@@ -1025,7 +1025,7 @@  CONFIG_IDLE_PAGE_TRACKING=y
 CONFIG_ARCH_HAS_CACHE_LINE_SIZE=y
 CONFIG_ARCH_HAS_PTE_DEVMAP=y
 CONFIG_ARCH_HAS_ZONE_DMA_SET=y
-# CONFIG_ZONE_DMA is not set
+CONFIG_ZONE_DMA=y
 CONFIG_ZONE_DMA32=y
 CONFIG_ZONE_DEVICE=y
 CONFIG_DEV_PAGEMAP_OPS=y
diff --git a/gnu/packages/aux-files/linux-libre/5.16-i686.conf b/gnu/packages/aux-files/linux-libre/5.16-i686.conf
index edaca0b891..a5773c54cf 100644
--- a/gnu/packages/aux-files/linux-libre/5.16-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/5.16-i686.conf
@@ -1000,7 +1000,7 @@  CONFIG_PAGE_IDLE_FLAG=y
 CONFIG_IDLE_PAGE_TRACKING=y
 CONFIG_ARCH_HAS_CACHE_LINE_SIZE=y
 CONFIG_ARCH_HAS_ZONE_DMA_SET=y
-# CONFIG_ZONE_DMA is not set
+CONFIG_ZONE_DMA=y
 CONFIG_HMM_MIRROR=y
 CONFIG_VMAP_PFN=y
 # CONFIG_PERCPU_STATS is not set
diff --git a/gnu/packages/aux-files/linux-libre/5.16-x86_64.conf b/gnu/packages/aux-files/linux-libre/5.16-x86_64.conf
index e8271dcef3..048056b456 100644
--- a/gnu/packages/aux-files/linux-libre/5.16-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.16-x86_64.conf
@@ -1032,7 +1032,7 @@  CONFIG_IDLE_PAGE_TRACKING=y
 CONFIG_ARCH_HAS_CACHE_LINE_SIZE=y
 CONFIG_ARCH_HAS_PTE_DEVMAP=y
 CONFIG_ARCH_HAS_ZONE_DMA_SET=y
-# CONFIG_ZONE_DMA is not set
+CONFIG_ZONE_DMA=y
 CONFIG_ZONE_DMA32=y
 CONFIG_ZONE_DEVICE=y
 CONFIG_DEV_PAGEMAP_OPS=y
diff --git a/gnu/packages/aux-files/linux-libre/5.4-x86_64.conf b/gnu/packages/aux-files/linux-libre/5.4-x86_64.conf
index ec8609171e..91b3033260 100644
--- a/gnu/packages/aux-files/linux-libre/5.4-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.4-x86_64.conf
@@ -294,7 +294,7 @@  CONFIG_CC_HAS_SANE_STACKPROTECTOR=y
 #
 # Processor type and features
 #
-# CONFIG_ZONE_DMA is not set
+CONFIG_ZONE_DMA=y
 CONFIG_SMP=y
 CONFIG_X86_FEATURE_NAMES=y
 CONFIG_X86_X2APIC=y