diff mbox series

[bug#53571] gnu: Add emacs-validate-html.

Message ID 20220127055425.18752-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#53571] gnu: Add emacs-validate-html. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Jan. 27, 2022, 5:54 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-validate-html): New variable.
---

Hi,

Here is another one I'm upstreaming from Guix 'R Us.

all best,

jgart

https://whereiseveryone.srht.site
gemini://whereiseveryone.srht.site

 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Nicolas Goaziou Jan. 28, 2022, 8:19 a.m. UTC | #1
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-validate-html): New variable.

Thank you. I applied it with the changes below:

> +(define-public emacs-validate-html
> +  (let ((commit "748e874d50c3a95c61590ae293778e26de05c5f9")
> +        (revision "0"))
> +    (package
> +      (name "emacs-validate-html")
> +      (version (git-version "0.1" revision commit))

Version is actually "1.3" per main file.  I also removed `revision'
since `commit' matches the latest version bump.

I also added a comment explaining the situation.

> +      (description
> +"@command{emacs-validate-html} installs the command @command{validate-html},
> +which sends the current buffer to the World Wide Web Consortium’s HTML
> +Validator service and displays the results in a buffer in Compilation
> +mode.  Use standard Compilation commands like next-error to move through
> +the errors in the source buffer.")
> +      (license license:gpl3+))))

I removed last sentence, which belongs to the package manual rather than
its description.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 258c2b25b5..fa8acf47e7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29917,6 +29917,33 @@  (define-public emacs-nasm-mode
 Unlike Emacs' generic ASM mode, it understands NASM-specific syntax.")
     (license license:unlicense)))
 
+(define-public emacs-validate-html
+  (let ((commit "748e874d50c3a95c61590ae293778e26de05c5f9")
+        (revision "0"))
+    (package
+      (name "emacs-validate-html")
+      (version (git-version "0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/arthurgleckler/validate-html")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0b2b5dm85jwgkqvga23r3vfya07vxv2n7a3a6r1pxpk8asqlw41c"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/arthurgleckler/validate-html")
+      (synopsis "Run the W3C HTML Validator directly from Emacs")
+      (description
+"@command{emacs-validate-html} installs the command @command{validate-html},
+which sends the current buffer to the World Wide Web Consortium’s HTML
+Validator service and displays the results in a buffer in Compilation
+mode.  Use standard Compilation commands like next-error to move through
+the errors in the source buffer.")
+      (license license:gpl3+))))
+
 (define-public emacs-global-tags
   (let ((commit "06db25d91cc8bfb5e24e02adc04de1226c7e742d")
         (revision "0"))