diff mbox series

[bug#53570] gnu: Add texlive-ddphonism.

Message ID 20220127055130.17895-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#53570] gnu: Add texlive-ddphonism. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Jan. 27, 2022, 5:51 a.m. UTC
* gnu/packages/tex.scm (texlive-ddphonism): New variable.
---

Hi,

This is a WIP.

Any feedback is much welcome.

all best,

jgart

 gnu/packages/tex.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Ludovic Courtès March 7, 2022, 8:24 p.m. UTC | #1
Hello,

jgart <jgart@dismail.de> skribis:

> * gnu/packages/tex.scm (texlive-ddphonism): New variable.
> ---
>
> Hi,
>
> This is a WIP.

What’s missing?

> Any feedback is much welcome.

I haven’t tested it but it LGTM.

Thanks,
Ludo’.
Maxim Cournoyer July 7, 2022, 6:45 p.m. UTC | #2
Hi,

Ludovic Courtès <ludo@gnu.org> writes:

> Hello,
>
> jgart <jgart@dismail.de> skribis:
>
>> * gnu/packages/tex.scm (texlive-ddphonism): New variable.
>> ---
>>
>> Hi,
>>
>> This is a WIP.
>
> What’s missing?
>
>> Any feedback is much welcome.
>
> I haven’t tested it but it LGTM.
>
> Thanks,
> Ludo’.

Ping :-)

Thanks,

Maxim
jgart July 8, 2022, 12:02 a.m. UTC | #3
On Thu, 07 Jul 2022 14:45:52 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
> Hi,
> 
> Ludovic Courtès <ludo@gnu.org> writes:
> 
> > Hello,
> >
> > jgart <jgart@dismail.de> skribis:
> >
> >> * gnu/packages/tex.scm (texlive-ddphonism): New variable.
> >> ---
> >>
> >> Hi,
> >>
> >> This is a WIP.
> >
> > What’s missing?
> >
> >> Any feedback is much welcome.
> >
> > I haven’t tested it but it LGTM.
> >
> > Thanks,
> > Ludo’.
> 
> Ping :-)

Hi, I'm not sure when I'll be able to get around to this one.

Maxim, would you like to take it over? It's a nice LaTeX package for twelve-tone music ;()

all best,

jgart
Maxim Cournoyer July 11, 2022, 3:47 p.m. UTC | #4
Hi jgart,

jgart <jgart@dismail.de> writes:

> On Thu, 07 Jul 2022 14:45:52 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
>> Hi,
>> 
>> Ludovic Courtès <ludo@gnu.org> writes:
>> 
>> > Hello,
>> >
>> > jgart <jgart@dismail.de> skribis:
>> >
>> >> * gnu/packages/tex.scm (texlive-ddphonism): New variable.
>> >> ---
>> >>
>> >> Hi,
>> >>
>> >> This is a WIP.
>> >
>> > What’s missing?
>> >
>> >> Any feedback is much welcome.
>> >
>> > I haven’t tested it but it LGTM.
>> >
>> > Thanks,
>> > Ludo’.
>> 
>> Ping :-)
>
> Hi, I'm not sure when I'll be able to get around to this one.
>
> Maxim, would you like to take it over? It's a nice LaTeX package for twelve-tone music ;()

I looked at it, but it seems it'd require packaging xstring in the first
place, as it the package '\RequirePackage{xstring}' it.

Perhaps we can revisit after we gain a useful texlive importer, or when
someone motivated steps in.  In the meantime, closing.

Thanks,

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 89f60f89d5..da47874ec6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9953,6 +9953,31 @@  (define-public texlive-xifthen
 handle complex tests.")
     (license license:lppl)))
 
+(define-public texlive-ddphonism
+  (package
+    (inherit (simple-texlive-package
+              "texlive-ddphonism"
+              (list "/tex/latex/ddphonism/ddphonism.sty"
+                     "/tex/latex/ddphonism/ddphonism.tex")
+              (base32
+               "09s324nj6g8nlib9wilpy01prixrw1ilwlvl638hgv5rxsspza5y")
+              #:trivial? #t))
+    (inputs
+      (list texlive-latex-hyperref 
+            texlive-latex-tools 
+            texlive-etoolbox
+            texlive-latex-pgf
+            texlive-latex-l3packages
+            texlive-latex-listings))
+    (home-page "https://www.ctan.org/pkg/ddphonism")
+    (synopsis "Dodecaphonic diagrams for LaTeX")
+    (description
+"This is a music-related package which is focused on notation from
+the Twelve-Tone System, also called Dodecaphonism.  It provides LaTeX
+algorithms that produce typical dodecaphonic notation based off a musical
+series, or row sequence, of variable length.")
+    (license license:lppl1.3c+)))
+
 (define-public bibtool
   (package
     (name "bibtool")