diff mbox series

[bug#53508] Add the package: python-multipart

Message ID 20220124173433.293164-1-contact@phfrohring.com
State Accepted
Headers show
Series [bug#53508] Add the package: python-multipart | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Pierre-Henry Fröhring Jan. 24, 2022, 5:34 p.m. UTC
From: Pierre-Henry Fröhring <phf@phf.net>

---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

2.31.1

Comments

Ludovic Courtès March 7, 2022, 8:49 p.m. UTC | #1
Hi,

Pierre-Henry Fröhring <contact@phfrohring.com> skribis:

> From: Pierre-Henry Fröhring <phf@phf.net>
>
> ---
>  gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
>  1 file changed, 26 insertions(+)

I tweaked the commit log as per our conventions and applied it.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8bd5f65..1a47f89 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28768,3 +28768,29 @@  implementation, so that it supports any Galois field higher than 2^3,
 but not binary streams.")
     (license license:public-domain)))
 
+(define-public python-multipart
+  (package
+    (name "python-multipart")
+    (version "0.0.5")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "python-multipart" version))
+              (sha256
+               (base32
+                "0hzshd665rl1bkwvaj9va4j3gs8nmb478fbvligx20663xhmzfzp"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-six))
+    (native-inputs (list python-pyyaml python-mock python-pytest-cov))
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  ;; There is a bug in the test_suit specification.
+                  (add-after 'unpack 'patch-test-suite
+                    (lambda _
+                      (substitute* "setup.py"
+                        (("test_suite = 'multipart.tests.suite'")
+                         "test_suite = 'multipart.tests.test_multipart.suite'")))))))
+    (home-page "https://github.com/andrew-d/python-multipart")
+    (synopsis "Streaming multipart parser for Python")
+    (description
+     "This package provides a streaming multipart parser for Python")
+    (license license:asl2.0)))