diff mbox series

[bug#53494] gnu: utf-8-lineseparator: Update to cj7.

Message ID 20220124054815.3276-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#53494] gnu: utf-8-lineseparator: Update to cj7. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Jan. 24, 2022, 5:48 a.m. UTC
* gnu/packages/textutils.scm (utf-8-lineseparator): Update to cj7.
---
 gnu/packages/textutils.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Liliana Marie Prikler Jan. 24, 2022, 4:26 p.m. UTC | #1
Am Montag, dem 24.01.2022 um 00:48 -0500 schrieb jgart:
> * gnu/packages/textutils.scm (utf-8-lineseparator): Update to cj7.
> ---
>  gnu/packages/textutils.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
> index 12e3d3b3c8..751b036f79 100644
> --- a/gnu/packages/textutils.scm
> +++ b/gnu/packages/textutils.scm
> @@ -1377,7 +1377,7 @@ (define-public go-github-com-errata-ai-vale
>  (define-public utf-8-lineseparator
>    (package
>      (name "utf-8-lineseparator")
> -    (version "cj3")
> +    (version "cj7")
>      (source (origin
>                (method git-fetch)
>                (uri (git-reference
> @@ -1386,7 +1386,7 @@ (define-public utf-8-lineseparator
>                (file-name (git-file-name name version))
>                (sha256
>                 (base32
> -               
> "1xnbcanqn5jr965gw9195ij6hz04clfm77m5776dysn9nykn20w1"))))
> +               
> "0lqwfrwq28246lja2gawf5jllh4smddswkpd5lscvc2ynylcmmzx"))))
>      (build-system gnu-build-system)
>      (arguments
>       `(#:make-flags
I know this ought to have been caught by whoever reviewed the package
back then, but is "cj" really a relevant part of the version?

Cheers
jgart Jan. 24, 2022, 5:45 p.m. UTC | #2
On Mon, 24 Jan 2022 17:26:45 +0100 Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:
> Am Montag, dem 24.01.2022 um 00:48 -0500 schrieb jgart:
> > * gnu/packages/textutils.scm (utf-8-lineseparator): Update to cj7.
> > ---
> >  gnu/packages/textutils.scm | 4 ++--
> >  1 file changed, 2 insertions(+), 2 deletions(-)
> > 
> > diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
> > index 12e3d3b3c8..751b036f79 100644
> > --- a/gnu/packages/textutils.scm
> > +++ b/gnu/packages/textutils.scm
> > @@ -1377,7 +1377,7 @@ (define-public go-github-com-errata-ai-vale
> >  (define-public utf-8-lineseparator
> >    (package
> >      (name "utf-8-lineseparator")
> > -    (version "cj3")
> > +    (version "cj7")
> >      (source (origin
> >                (method git-fetch)
> >                (uri (git-reference
> > @@ -1386,7 +1386,7 @@ (define-public utf-8-lineseparator
> >                (file-name (git-file-name name version))
> >                (sha256
> >                 (base32
> > -               
> > "1xnbcanqn5jr965gw9195ij6hz04clfm77m5776dysn9nykn20w1"))))
> > +               
> > "0lqwfrwq28246lja2gawf5jllh4smddswkpd5lscvc2ynylcmmzx"))))
> >      (build-system gnu-build-system)
> >      (arguments
> >       `(#:make-flags
> I know this ought to have been caught by whoever reviewed the package
> back then, but is "cj" really a relevant part of the version?

Hi lilyp, 

That's the author's system for version releases.

They're not using semver. See the hugs module/system for one example of
a versioning system that is not semver in upstream GNU/Guix.

all best,

jgart
jgart Jan. 24, 2022, 6 p.m. UTC | #3
On Mon, 24 Jan 2022 12:45:33 -0500 jgart <jgart@dismail.de> wrote:
> is "cj" really a relevant part of the version?

https://github.com/pflanze/utf-8-lineseparator/archive/refs/tags/cj7.tar.gz
Liliana Marie Prikler Jan. 24, 2022, 6:10 p.m. UTC | #4
Hi,

Am Montag, dem 24.01.2022 um 12:45 -0500 schrieb jgart:
> On Mon, 24 Jan 2022 17:26:45 +0100 Liliana Marie Prikler
> <liliana.prikler@gmail.com> wrote:
> > Am Montag, dem 24.01.2022 um 00:48 -0500 schrieb jgart:
> > > * gnu/packages/textutils.scm (utf-8-lineseparator): Update to
> > > cj7.
> > > ---
> > >  gnu/packages/textutils.scm | 4 ++--
> > >  1 file changed, 2 insertions(+), 2 deletions(-)
> > > 
> > > diff --git a/gnu/packages/textutils.scm
> > > b/gnu/packages/textutils.scm
> > > index 12e3d3b3c8..751b036f79 100644
> > > --- a/gnu/packages/textutils.scm
> > > +++ b/gnu/packages/textutils.scm
> > > @@ -1377,7 +1377,7 @@ (define-public go-github-com-errata-ai-vale
> > >  (define-public utf-8-lineseparator
> > >    (package
> > >      (name "utf-8-lineseparator")
> > > -    (version "cj3")
> > > +    (version "cj7")
> > >      (source (origin
> > >                (method git-fetch)
> > >                (uri (git-reference
> > > @@ -1386,7 +1386,7 @@ (define-public utf-8-lineseparator
> > >                (file-name (git-file-name name version))
> > >                (sha256
> > >                 (base32
> > > -               
> > > "1xnbcanqn5jr965gw9195ij6hz04clfm77m5776dysn9nykn20w1"))))
> > > +               
> > > "0lqwfrwq28246lja2gawf5jllh4smddswkpd5lscvc2ynylcmmzx"))))
> > >      (build-system gnu-build-system)
> > >      (arguments
> > >       `(#:make-flags
> > I know this ought to have been caught by whoever reviewed the
> > package
> > back then, but is "cj" really a relevant part of the version?
> 
> Hi lilyp, 
> 
> That's the author's system for version releases.
> 
> They're not using semver. See the hugs module/system for one example
> of a versioning system that is not semver in upstream GNU/Guix.
That doesn't answer my question and instead just raises more.  We
typically strip meaningless version prefixes such as "v", (weird)
spellings of the package name, etc.  Why is cj special in this regard?

Also for hugs, we could be using CalVer as far as I can see, though
it's unlikely to receive a version bump after 15 years.

Cheers
Liliana Marie Prikler Jan. 24, 2022, 7:17 p.m. UTC | #5
Am Montag, dem 24.01.2022 um 13:00 -0500 schrieb jgart:
> On Mon, 24 Jan 2022 12:45:33 -0500 jgart <jgart@dismail.de> wrote:
> > is "cj" really a relevant part of the version?
> 
> https://github.com/pflanze/utf-8-lineseparator/archive/refs/tags/cj7.tar.gz
You're not answering the question.  I can read the tag myself, I want
to know how to interpret it.
jgart Jan. 25, 2022, 4:06 a.m. UTC | #6
On Mon, 24 Jan 2022 20:17:48 +0100 Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:

> I know this ought to have been caught by whoever reviewed the package
> back then, but is "cj" really a relevant part of the version?

Hi lilyp,

Sorry, I was under the impression that all packages did not have to
follow a particular versioning scheme such as SemVer or CalVer. Is that
part of official Guix Policy that I can read somewhere?

I'm cc'ing Ludovic to see if there is a differing opinion on the
topic given that Ludo had reviewed and merged the utf-8-lineseparator
tool/framework.

all best,

jgart
Ludovic Courtès Jan. 25, 2022, 1:52 p.m. UTC | #7
Hi,

jgart <jgart@dismail.de> skribis:

> On Mon, 24 Jan 2022 20:17:48 +0100 Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:
>
>> I know this ought to have been caught by whoever reviewed the package
>> back then, but is "cj" really a relevant part of the version?

I overlooked that bit; “cj3” doesn’t look like a version number, indeed.

> Sorry, I was under the impression that all packages did not have to
> follow a particular versioning scheme such as SemVer or CalVer. Is that
> part of official Guix Policy that I can read somewhere?

There’s no policy regarding semver & co: packages can do what they want.

However, the Guix CLI assumes “normal” version numbers, meaning a string
that starts with dot-separated digits.  ‘guix upgrade’, for instance,
compares version strings to determine what’s being upgraded, so those
strings have to be “normal” version strings.

jgart, is “cj7” the version string upstream?  In that case, can we
change it to “7” or “7.cj” or something along these lines?

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 12e3d3b3c8..751b036f79 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1377,7 +1377,7 @@  (define-public go-github-com-errata-ai-vale
 (define-public utf-8-lineseparator
   (package
     (name "utf-8-lineseparator")
-    (version "cj3")
+    (version "cj7")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1386,7 +1386,7 @@  (define-public utf-8-lineseparator
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1xnbcanqn5jr965gw9195ij6hz04clfm77m5776dysn9nykn20w1"))))
+                "0lqwfrwq28246lja2gawf5jllh4smddswkpd5lscvc2ynylcmmzx"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags