diff mbox series

[bug#53474] gnu: Add emacs-all-the-icons-completion.

Message ID 20220123140337.1185963-1-br@ndon.dk
State Accepted
Headers show
Series [bug#53474] gnu: Add emacs-all-the-icons-completion. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Brandon Jan. 23, 2022, 2:03 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-all-the-icons-completion): New
  variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

--
2.34.0

Comments

Nicolas Goaziou Jan. 23, 2022, 5:29 p.m. UTC | #1
Hello,

Brandon Lucas <br@ndon.dk> writes:

> * gnu/packages/emacs-xyz.scm (emacs-all-the-icons-completion): New
>   variable.

Thank you.

> +  ;; No tags. Version comes from latest melpa build.
> +  (let ((commit "9e7d456b0934ecb568b6f05a8445e3f4ce32261f")
> +        (revision "0"))
> +    (package
> +      (name "emacs-all-the-icons-completion")
> +      (version (git-version "20220106.1310" revision commit))

We don't use fancy MELPA versioning. In this situation, base version is
extracted from "Version" keyword in the header of the main file.

> +      (description "Add icons to completion candidates using the built in
> +completion metadata functions.  For example, with this package, @code{find-file}
> +can display a file icon for each candidate based on the file type.")

I reworded the first sentence so it would be complete.

Applied!

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8edbfc5a3d..db514e1145 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22311,6 +22311,31 @@  (define-public emacs-all-the-icons
     (license
      (list license:expat license:gpl3+ license:silofl1.1 license:asl2.0))))

+(define-public emacs-all-the-icons-completion
+  ;; No tags. Version comes from latest melpa build.
+  (let ((commit "9e7d456b0934ecb568b6f05a8445e3f4ce32261f")
+        (revision "0"))
+    (package
+      (name "emacs-all-the-icons-completion")
+      (version (git-version "20220106.1310" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/iyefrat/all-the-icons-completion")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "04bnmmd6lyx0p39sgymqvmcy7bk8mr7sikbpy49adxi7d2891ldg"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-all-the-icons))
+      (home-page "https://github.com/iyefrat/all-the-icons-completion")
+      (synopsis "Add icons to completion candidates")
+      (description "Add icons to completion candidates using the built in
+completion metadata functions.  For example, with this package, @code{find-file}
+can display a file icon for each candidate based on the file type.")
+      (license license:gpl3+))))
+
 (define-public emacs-wttrin
   (let ((commit "df5427ce2a5ad4dab652dbb1c4a1834d7ddc2abc")
         (revision "1"))