diff mbox series

[bug#53473] gnu: Add emacs-fixed-pitch.

Message ID 20220123134221.1174002-1-br@ndon.dk
State Accepted
Headers show
Series [bug#53473] gnu: Add emacs-fixed-pitch. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Brandon Jan. 23, 2022, 1:42 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-fixed-pitch): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

--
2.34.0

Comments

Nicolas Goaziou Jan. 23, 2022, 5:02 p.m. UTC | #1
Hello,

Brandon Lucas <br@ndon.dk> writes:

> * gnu/packages/emacs-xyz.scm (emacs-fixed-pitch): New variable.

Thank you.

I applied your patch with the changes below.

> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/cstby/fixed-pitch-mode")
> +             (commit "f26f96ab65c8452553d803fc39509481ac6b7239")))

I used a tag, namely "v0.1.0" created with (string-append "v" version),
instead of a raw git commit.

Note that if you need to use such a reference, please let-bind it to
`commit' at the beginning of the package and use (commit commit)
instead.

> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "0qlavjvib0r71xdy6y6pan9dhr57lw7jhmqk60mwa8fq6km8kpkj"))))
> +    (build-system emacs-build-system)
> +    (home-page "https://github.com/cstby/fixed-pitch-mode")
> +    (synopsis "Minor mode for setting a monospaced typeface")
> +    (description
> +     "Use a minor mode for setting a monospace typeface, so you can set a
> + proportional typeface for UI elements while keeping a monospaced typeface
> + for code.")

I reworded synopsis and description.

> +    (license license:gpl3)))

The license is actually gpl3+ as the main file has "either version 3 of
the License, or ;; (at your option) any later version." in its header.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8edbfc5a3d..73277c06de 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19649,6 +19649,28 @@  (define-public emacs-default-text-scale
 decreasing the default font size in all GUI Emacs frames.")
     (license license:gpl3+)))

+(define-public emacs-fixed-pitch
+  (package
+    (name "emacs-fixed-pitch")
+    (version "0.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/cstby/fixed-pitch-mode")
+             (commit "f26f96ab65c8452553d803fc39509481ac6b7239")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0qlavjvib0r71xdy6y6pan9dhr57lw7jhmqk60mwa8fq6km8kpkj"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/cstby/fixed-pitch-mode")
+    (synopsis "Minor mode for setting a monospaced typeface")
+    (description
+     "Use a minor mode for setting a monospace typeface, so you can set a
+ proportional typeface for UI elements while keeping a monospaced typeface
+ for code.")
+    (license license:gpl3)))
+
 (define-public emacs-mixed-pitch
   (package
     (name "emacs-mixed-pitch")