diff mbox series

[bug#53472] gnu: Add emacs-nim-mode

Message ID 20220123133837.1035-1-paren@disroot.org
State Accepted
Headers show
Series [bug#53472] gnu: Add emacs-nim-mode | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( Jan. 23, 2022, 1:38 p.m. UTC
* gnu/packages/emacs-xyz.scm(emacs-nim-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

M Jan. 23, 2022, 4:21 p.m. UTC | #1
(unmatched-parenthesis via Guix-patches via schreef op zo 23-01-2022 om
13:38 [+0000]:
> +      (version (git-version "0.4.1" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/nim-lang/nim-mode")
> +               (commit version)))

I don't think there's a tag by the name "0.4.1-23.744e076"
in the git repo.  Try (git-reference ... (commit commit)) instead.

Greetings,
Maxime.
dziltener--- via Guix-patches via Jan. 24, 2022, 6:30 p.m. UTC | #2
> I don't think there's a tag by the name "0.4.1-23.744e076"
> in the git repo. Try (git-reference ... (commit commit)) instead.

Oops! I automatically wrote (commit version) out of habit :)
One moment...
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8edbfc5a3d..d2508748a9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -107,6 +107,7 @@ 
 ;;; Copyright © 2021 Brian Kubisiak <brian@kubisiak.com>
 ;;; Copyright © 2021, 2022 Taiju HIGASHI <higashi@taiju.info>
 ;;; Copyright © 2022 Brandon Lucas <br@ndon.dk>
+;;; Copyright © 2022 (unmatched parenthesis <paren@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -29837,3 +29838,31 @@  (define-public emacs-fennel-mode
      "Fennel mode provides font-lock, indentation, navigation, and REPL for
  Fennel code within Emacs.")
     (license license:gpl3+)))
+
+(define-public emacs-nim-mode
+  ;; The last tag was 0.4.1 in 2017. There have been many more commits since then.
+  (let ((commit "744e076f0bea1c5ddc49f92397d9aa98ffa7eff8")
+        (revision "0"))
+    (package
+      (name "emacs-nim-mode")
+      (version (git-version "0.4.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/nim-lang/nim-mode")
+               (commit version)))
+         (sha256
+          (base32 "0dwas3ivhxdyw6njkcadc8c17cirq325cmby04qls8zkmrvlil1w"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/nim-lang/nim-mode")
+      (synopsis "Major mode for editing Nim source code")
+      (description "This package provides major modes for Nim:
+@itemize
+@item Syntax highlighting for Nim code, Nimble configuration files, and nim.cfg
+@item `M-x nim-compile`, which can also be invoked with `C-c C-c` inside a Nim source file
+@item File outline by procedures
+@item Indentation and line breaking (alpha)
+@item Integration with nimsuggest, the Nim linting and completion server (alpha, both nimsuggest-mode and nimsuggest itself are currently VERY unstable and may make emacs much less responsive)
+@end itemize")
+      (license license:gpl3+))))