diff mbox series

[bug#53471] gnu: Add emacs-minimap.

Message ID 20220123133204.1167960-1-br@ndon.dk
State Accepted
Headers show
Series [bug#53471] gnu: Add emacs-minimap. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Brandon Jan. 23, 2022, 1:32 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-minimap): New variable.
---
 gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

--
2.34.0

Comments

Nicolas Goaziou Jan. 23, 2022, 4:49 p.m. UTC | #1
Hello,

Brandon Lucas <br@ndon.dk> writes:

> * gnu/packages/emacs-xyz.scm (emacs-minimap): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8edbfc5a3d..2ce2b6070b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26678,6 +26678,36 @@  (define-public emacs-minibuffer-line
 variable and the @code{minibuffer-line} face.")
     (license license:gpl3+)))

+(define-public emacs-minimap
+  (package
+    (name "emacs-minimap")
+    (version "1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://elpa.gnu.org/packages/minimap-"
+             version
+             ".el"))
+       (sha256
+        (base32 "09fm0ziy8cdzzw08l7l6p63dxz2a27p3laia2v51mvbva8177ls1"))))
+    (build-system emacs-build-system)
+    (home-page "http://elpa.gnu.org/packages/minimap.html")
+    (synopsis "Sidebar showing a 'mini-map' of a buffer")
+    (description
+     "Minimap provides Emacs with a minimap sidebar, which is a
+ smaller display of the current buffer on the side, like a scrollbar.  It
+ highlights the currently shown region and updates its position automatically.
+ You can navigate in the minibar by dragging the active region with the mouse,
+ which will scroll the corresponding edit buffer.
+ Additionally, you can overlay information from the tags gathered by CEDET's
+ semantic analyzer.
+
+ Use M-x minimap-mode to toggle activation of the minimap.
+ Use 'M-x customize-group RET minimap RET' to adapt minimap to your
+ needs.")
+    (license license:gpl3+)))
+
 (define-public emacs-eshell-prompt-extras
   (package
     (name "emacs-eshell-prompt-extras")