diff mbox series

[bug#53456,v2,1/2] gnu: Add fnlfmt.

Message ID 20220123001509.484504-1-br@ndon.dk
State Accepted
Headers show
Series [bug#53456,v2,1/2] gnu: Add fnlfmt. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Brandon Jan. 23, 2022, 12:16 a.m. UTC
* gnu/packages/lua.scm (fnlfmt): New variable.
---
Thank you for the review. I learned a lot. :)

I also realized that if I truly unbundle fennel from fnlfmt, I also need
to wrap it, so that it can load fennel at runtime. It only worked before
because I had failed to remove the fennel.lua file from the checkout.

I have tried to apply your other suggestions here as well.

I will also write to upstream and attempt to get the licensing
clarified.

 gnu/packages/lua.scm | 65 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 65 insertions(+)

--
2.34.0

Comments

M Jan. 23, 2022, 11:05 a.m. UTC | #1
Brandon Lucas schreef op zo 23-01-2022 om 00:16 [+0000]:
> +                   (delete-file-recursively "fennel")
> +                   (delete-file-recursively "fennel.lua")

This is not wrong, but 'fennel' and 'fennel.lua' are regular files and
not directories, so (delete-file "fennel") (delete-file "fennel.lua")
would be sufficient.
M Jan. 23, 2022, 11:11 a.m. UTC | #2
Brandon Lucas schreef op zo 23-01-2022 om 00:16 [+0000]:
> +    (inputs (list bash-minimal lua fennel))

'fennel' is used as a tool run during building
(https://git.sr.ht/~technomancy/fnlfmt/tree/main/item/Makefile#L3),
so it needs to be in native-inputs.  It is also used as a kind of
library (see LUA_PATH in 'wrap' phase), so it needs to be in
native-inputs as well.

Summarised: 'fennel' needs to be in both inputs and native-inputs.

As a test, you can try to cross-compile fnlfmt:

# warning: this will first build a cross-compiler wich will take a lot
# of time
$ ./pre-inst-env guix build fnlfmt --target=aarch64-linux-gnu

It is not guaranteed that if it builds, it will work, but it is a
useful test.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 99f09a26f1..1543d7bd11 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -15,6 +15,7 @@ 
 ;;; Copyright © 2020 Paul A. Patience <paul@apatience.com>
 ;;; Copyright © 2021 Vinícius dos Santos Oliveira <vini.ipsmaker@gmail.com>
 ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2022 Brandon Lucas <br@ndon.dk>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,12 +37,14 @@  (define-module (gnu packages lua)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (guix gexp)
   #:use-module (guix utils)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system trivial)
   #:use-module (gnu packages)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages build-tools)
   #:use-module (gnu packages glib)
@@ -1208,3 +1211,65 @@  (define-public fennel
 simplicity, and reach of Lua with the flexibility of a Lisp syntax and macro
 system.")
     (license license:expat)))
+
+(define-public fnlfmt
+  (package
+    (name "fnlfmt")
+    (version "0.2.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~technomancy/fnlfmt")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1rv0amqhy5ypi3pvxfaadn3k1cy4mjlc49wdzl2psz3i11w9gr36"))
+              (modules '((guix build utils)))
+              (snippet
+               #~(begin
+                   ;; Use input fennel instead of bundled fennel.
+                   (delete-file-recursively "fennel")
+                   (delete-file-recursively "fennel.lua")
+                   (substitute* "Makefile"
+                     (("./fennel") "fennel"))))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:modules ((guix build gnu-build-system)
+                  (guix build utils)
+                  (ice-9 match))
+       #:test-target "test"
+       #:phases
+       (modify-phases %standard-phases
+        (delete 'configure)
+        (add-before 'build 'patch-makefile
+         (lambda* (#:key native-inputs inputs #:allow-other-keys)
+          (substitute* "Makefile"
+           ;; Patch lua shebang that gets inserted to fnlfmt.
+           (("/usr/bin/env lua")
+            (search-input-file (or native-inputs inputs) "/bin/lua")))))
+        (replace 'install
+         ;; There is no install target; manually install the output file.
+         (lambda* (#:key outputs #:allow-other-keys)
+          (let* ((out (assoc-ref outputs "out"))
+                 (bin (string-append out "/bin")))
+           (for-each (lambda (file)
+                      (install-file file bin))
+            (find-files "." "fnlfmt")))))
+        (add-after 'install 'wrap
+         (lambda* (#:key inputs native-inputs outputs #:allow-other-keys)
+          (let* ((all-inputs (or native-inputs inputs))
+                 (fnlfmt (assoc-ref outputs "out"))
+                 (lua-version ,(version-major+minor (package-version lua)))
+                 (fennel (assoc-ref all-inputs "fennel")))
+           (wrap-program (string-append fnlfmt "/bin/fnlfmt")
+            `("LUA_PATH" ";" suffix
+              (,(format #f "~a/share/lua/~a/?.lua" fennel lua-version))))
+           #t))))))
+    (inputs (list bash-minimal lua fennel))
+    (home-page "https://git.sr.ht/~technomancy/fnlfmt")
+    (synopsis "Automatic formatting of Fennel code")
+    (description
+     "Fnlfmt is a tool for automatically formatting Fennel code in a consistent
+way, following established lisp conventions.")
+    (license license:lgpl3+)))