diff mbox series

[bug#53401,09/49] gnu: Add rust-password-hash 0.3 and 0.1.4.

Message ID 20220120215045.24768-9-attila@lendvai.name
State Accepted
Headers show
Series None | expand

Commit Message

Attila Lendvai Jan. 20, 2022, 9:50 p.m. UTC
* gnu/packages/crates-io.scm (rust-password-hash-0.3):
(rust-password-hash-0.1): New variables.
---
 gnu/packages/crates-io.scm | 46 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 32873c8eea..c70556e73e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -65617,6 +65617,52 @@  (define-public rust-packed-struct
     ;; User can choose either license.
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-password-hash-0.3
+  (package
+    (name "rust-password-hash")
+    (version "0.3.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "password-hash" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32 "1n7ig9j5x2q0fk12nny40faggrs0ra5bbxp6gz5yghfwlqw1ay8x"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+        (("rust-base64ct" ,rust-base64ct-1)
+         ("rust-rand-core" ,rust-rand-core-0.6)
+         ("rust-subtle" ,rust-subtle-2))))
+    (home-page
+      "https://github.com/RustCrypto/traits/tree/master/password-hash")
+    (synopsis
+      "Traits which describe the functionality of password hashing algorithms")
+    (description
+      "Traits which describe the functionality of password hashing algorithms,
+as well as a `no_std`-friendly implementation of the PHC string format (a
+well-defined subset of the Modular Crypt Format a.k.a. MCF)")
+    (license (list license:expat license:asl2.0))))
+
+(define-public rust-password-hash-0.1
+  (package
+    (inherit rust-password-hash-0.3)
+    (name "rust-password-hash")
+    (version "0.1.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "password-hash" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32 "1ymh3np2bamjy8rszimksxcp264dclil4620bxm8rff9pyj6m62l"))))
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+        (("rust-base64ct" ,rust-base64ct-1)
+         ("rust-rand-core" ,rust-rand-core-0.6))))))
+
 (define-public rust-piper-0.1
   (package
     (name "rust-piper")