diff mbox series

[bug#53364,27/28] gnu: Add python-urlgrabber.

Message ID 20220119140916.41578-27-monego@posteo.net
State Accepted
Headers show
Series [bug#53364,01/28] gnu: Remove python2-sphinxcontrib-programoutput. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Jan. 19, 2022, 2:09 p.m. UTC
* gnu/packages/python-web.scm (python-urlgrabber): New variable.
---
 gnu/packages/python-web.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b29be2dc5a..36c77f35ef 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4080,6 +4080,35 @@  variety of features, from launching web applications to bootstrapping project
 layouts.")
     (license license:expat)))
 
+(define-public python-urlgrabber
+  (package
+    (name "python-urlgrabber")
+    (version "4.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "urlgrabber" version))
+       (sha256
+        (base32 "0fg16zlw49cw7pjq9dhpc5vd35d5zz1mlki55m464qxfmfpzhnh7"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "test/runtests.py")))))))
+    (propagated-inputs
+     (list python-pycurl python-setuptools python-six))
+    (home-page "http://urlgrabber.baseurl.org/") ; no HTTPS
+    (synopsis "High-level cross protocol url-grabber")
+    (description
+     "@code{urlgrabber} is a library that unifies access to files available on
+the web, FTP or locally.  It supports HTTP, FTP and file:// protocols, it
+supports features like HTTP keep-alive, reget, throttling and more.")
+    (license license:lgpl2.1+)))
+
 (define-public python2-urlgrabber
   (package
     (name "python2-urlgrabber")