diff mbox series

[bug#53349,5/9] gnu: Add r-scico.

Message ID 20220118175418.1559782-5-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#53349,1/9] gnu: r-org-dr-eg-db: Update to 3.14.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier Jan. 18, 2022, 5:54 p.m. UTC
* gnu/packages/cran.scm (r-scico): New variable.
---
 gnu/packages/cran.scm | 26 +++++++++++++++++++++++++-
 1 file changed, 25 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ce7655e6a6..2caa12031b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31,7 +31,7 @@ 
 ;;; Copyright © 2020 Antoine Côté <antoine.cote@posteo.net>
 ;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2020 Magali Lemes <magalilemes00@gmail.com>
-;;; Copyright © 2020, 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2020, 2021, 2022 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2020 Aniket Patil <aniket112.patil@gmail.com>
 ;;; Copyright © 2021 Marcel Schilling <marcel.schilling@uni-luebeck.de>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
@@ -27108,6 +27108,30 @@  (define-public r-warp
 observations.")
     (license license:expat)))
 
+(define-public r-scico
+  (package
+    (name "r-scico")
+    (version "1.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "scico" version))
+       (sha256
+        (base32 "08grfbjd5s0vdw76ni37yjl2242rr8i2jy72sgpwgra282hpnji3"))))
+    (properties `((upstream-name . "scico")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-scales))
+    (home-page "https://github.com/thomasp85/scico")
+    (synopsis "Colour Palettes Based on the Scientific Colour-Maps")
+    (description
+     "This package provides colour choice in information visualisation.  It
+important in order to avoid being mislead by inherent bias in the used colour
+palette.  This package provides access to the perceptually uniform and
+colour-blindness friendly palettes developed by Fabio Crameri and released
+under the \"Scientific Colour-Maps\" moniker.  The package contains 24
+different palettes and includes both diverging and sequential types.")
+    (license license:expat)))
+
 (define-public r-slider
   (package
     (name "r-slider")