diff mbox series

[bug#53336] qbittorent: Bump 4.2.5 -> 4.4.0

Message ID 20220118032800.19497-1-kreyren@rixotstudio.cz
State Accepted
Headers show
Series [bug#53336] qbittorent: Bump 4.2.5 -> 4.4.0 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jacob Hrbek Jan. 18, 2022, 3:28 a.m. UTC
Signed-off-by: Jacob Hrbek <kreyren@rixotstudio.cz>
---
 gnu/packages/bittorrent.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

--
2.34.0

Comments

M Jan. 19, 2022, 9:04 a.m. UTC | #1
Jacob Hrbek schreef op di 18-01-2022 om 03:28 [+0000]:
> Signed-off-by: Jacob Hrbek <kreyren@rixotstudio.cz>

FWIW, this isn't what ‘Signed-off-by’ means in Guix.  From ‘17.8.2
Commit policy’:

When pushing a commit on behalf of somebody else, please add a
‘Signed-off-by’ line at the end of the commit log message—e.g., with
‘git am --signoff’. This improves tracking of who did what.

Greetings,
Maxime.
M Jan. 19, 2022, 11:43 a.m. UTC | #2
[Please keep debbugs in CC or To]

Jacob Hrbek schreef op wo 19-01-2022 om 09:49 [+0000]:
> I don't have commit access so it's projected to be merged by
> privileged developer on my behalf thus the signed-off-by line so that
> i am not held liable (i am aware that GPLv3 has no liability clause)
> for the changes as GNU Guix lacks sufficient QA for the changes imho.

That's neither what that line means in Guix and neither what it means
in Linux (*) (the project that introduced the original Signed-off-by
IIUC), so I don't see where you got this interpretation about Signed-
off-by and liability from.

(*) See Documentation/process/submitting-patches.rst

In fact, Signed-off-by indicates a measure of ‘approval’ (in Guix
quite a bit more than in Linux IIUC) -- it's not explicitly spelled
out, but Linux' and Guix' contributing documentation seems too imply
this to some degree.

As such, assuming ‘Signed-off-by’ impacts liability somehow,
I would find it more likely that it would increase the chance
of being held liable than decreasing the chance of being held
liable.  Or maybe the inverse holds, who knows, I don't know
how liability and responsibility works legally.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index fa88c91163..ddcfda17f5 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -466,7 +466,7 @@  (define-public libtorrent-rasterbar
 (define-public qbittorrent
   (package
     (name "qbittorrent")
-    (version "4.2.5")
+    (version "4.4.0")
     (source
      (origin
        (method git-fetch)
@@ -475,7 +475,7 @@  (define-public qbittorrent
              (commit (string-append "release-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1n613ylg6i9gisgk0dbr2kpfasyizrkdjff1r8smd4vri2qrdksn"))))
+        (base32 "0aqrcwxi3s2alila3fa7fjs4hifkq7055wa4xvz17hajchs3l567"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags