diff mbox series

[bug#53312] gnu: Add sxmo-st.

Message ID 20220117042810.8072-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#53312] gnu: Add sxmo-st. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Jan. 17, 2022, 4:28 a.m. UTC
* gnu/packages/suckless.scm (sxmo-st): New variable.
---

Hi Guixers,

This is the st for sxmo:

https://sxmo.org/

Sxmo is a minimalist environment for Linux mobile devices, such as the pinephone.

I'm upstreaming this from guixrus channel:

https://git.sr.ht/~whereiseveryone/guixrus/tree/master/item/guixrus/packages/suckless.scm#L219

all best,

jgart

https://whereiseveryone.srht.site/
gemini://whereiseveryone.srht.site/

 gnu/packages/suckless.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Maxim Cournoyer July 7, 2022, 6:44 p.m. UTC | #1
Hi jgart,

jgart <jgart@dismail.de> writes:

> * gnu/packages/suckless.scm (sxmo-st): New variable.
> ---
>
> Hi Guixers,
>
> This is the st for sxmo:
>
> https://sxmo.org/
>
> Sxmo is a minimalist environment for Linux mobile devices, such as the pinephone.
>
> I'm upstreaming this from guixrus channel:
>
> https://git.sr.ht/~whereiseveryone/guixrus/tree/master/item/guixrus/packages/suckless.scm#L219

Have you tried it on a Pinephone?  Did it work?

Thanks,

Maxim
jgart July 8, 2022, 12:05 a.m. UTC | #2
On Thu, 07 Jul 2022 14:44:42 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
> Hi jgart,
> 
> jgart <jgart@dismail.de> writes:
> 
> > * gnu/packages/suckless.scm (sxmo-st): New variable.
> > ---
> >
> > Hi Guixers,
> >
> > This is the st for sxmo:
> >
> > https://sxmo.org/
> >
> > Sxmo is a minimalist environment for Linux mobile devices, such as the pinephone.
> >
> > I'm upstreaming this from guixrus channel:
> >
> > https://git.sr.ht/~whereiseveryone/guixrus/tree/master/item/guixrus/packages/suckless.scm#L219
> 
> Have you tried it on a Pinephone?  Did it work?

Unfortunately, my pinphone pro got donated to the salvation army[1] before I could do so (long story).

[1]: https://en.wikipedia.org/wiki/The_Salvation_Army

I imagine it should work but maybe someone can test this?

The pinephone is too slow to run guix (im my experience) but the pinephone pro might be a good candidate with it's CPU specs.

all best,

jgart
jgart July 8, 2022, 12:06 a.m. UTC | #3
On Thu, 07 Jul 2022 19:05:24 -0500 jgart <jgart@dismail.de> wrote:
> On Thu, 07 Jul 2022 14:44:42 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
> > Hi jgart,
> > 
> > jgart <jgart@dismail.de> writes:
> > 
> > > * gnu/packages/suckless.scm (sxmo-st): New variable.
> > > ---
> > >
> > > Hi Guixers,
> > >
> > > This is the st for sxmo:
> > >
> > > https://sxmo.org/
> > >
> > > Sxmo is a minimalist environment for Linux mobile devices, such as the pinephone.
> > >
> > > I'm upstreaming this from guixrus channel:
> > >
> > > https://git.sr.ht/~whereiseveryone/guixrus/tree/master/item/guixrus/packages/suckless.scm#L219
> > 
> > Have you tried it on a Pinephone?  Did it work?
> 
> Unfortunately, my pinphone pro got donated to the salvation army[1] before I could do so (long story).
> 
> [1]: https://en.wikipedia.org/wiki/The_Salvation_Army
> 
> I imagine it should work but maybe someone can test this?
> 
> The pinephone is too slow to run guix (im my experience) but the pinephone pro might be a good candidate with it's CPU specs.
> 
> all best,
> 
> jgart

I had installed Guix on mobian. This is probably the easiest way to install Guix on the pinephone since it is just a `sudo apt install guix` away.
Maxim Cournoyer July 11, 2022, 4 p.m. UTC | #4
Hi jgart,

jgart <jgart@dismail.de> writes:

[...]

>> I imagine it should work but maybe someone can test this?
>> 
>> The pinephone is too slow to run guix (im my experience) but the
>> pinephone pro might be a good candidate with it's CPU specs.
>> 
>> all best,
>> 
>> jgart
>
> I had installed Guix on mobian. This is probably the easiest way to
> install Guix on the pinephone since it is just a `sudo apt install
> guix` away.

Thanks for the precisions.  I better understand the use case now.

Pushed with 6ffb3ef4d61e47c39b9ee4d1dceeaeb9360094c0.

Thanks!

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index cfeb17e533..09e17c5831 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -459,6 +459,25 @@  (define-public lukesmithxyz-st
 Vim bindings and Xresource compatibility.")
       (license license:expat))))
 
+(define-public sxmo-st
+  (package
+    (inherit st)
+    (name "sxmo-st")
+    (version "0.8.4.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://git.sr.ht/~mil/sxmo-st")
+         (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1nl40q1pxf46hpbibz9m9d0giiy1p3lrhr9agw0fkyba2vzbbafa"))))
+    (home-page "https://git.sr.ht/~mil/sxmo-st")
+    (synopsis "St terminal emulator for the Simple X Mobile PinePhone environment")
+    (license license:expat)))
+
 (define-public surf
   (package
     (name "surf")