diff mbox series

[bug#53303] qBitTorrent: Bump version to avoid search engine fail

Message ID 20220116125456.1265-1-kreyren@rixotstudio.cz
State Accepted
Headers show
Series [bug#53303] qBitTorrent: Bump version to avoid search engine fail | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jacob Hrbek Jan. 16, 2022, 12:55 p.m. UTC
On version 4.2.0 the search engine fails with:

```
Missing Python Runtime

Python is required to use the search engine but it does not seem to be installed.
```

Steps to verify:
1. Get qBitTorrent on GNU Guix (374fea0f3bc8035f626cb29e6045130df9ffdaf8) or relevant release with qbittorrent 4.2.0
2. Open qbittorrent and in GUI navigate: `View -> Search Engine`
3. Expect the highlighted failure

Relevant: https://github.com/qbittorrent/qBittorrent/issues/16139
---
 gnu/packages/bittorrent.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

@@ -475,7 +475,7
@@ (define-public qbittorrent
              (commit (string-append "release-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1n613ylg6i9gisgk0dbr2kpfasyizrkdjff1r8smd4vri2qrdksn"))))
+        (base32 "0aqrcwxi3s2alila3fa7fjs4hifkq7055wa4xvz17hajchs3l567"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
--
2.34.0

Comments

Jacob Hrbek Jan. 16, 2022, 1:02 p.m. UTC | #1
DO NOT MERGE it fails again... seems to be on random investigating

On 1/16/22 13:57, help-debbugs@gnu.org wrote:
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
>   guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 53303@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 53303: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=53303
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems

--
Jacob Hrbek
Jacob Hrbek Jan. 19, 2022, 6:24 a.m. UTC | #2
obsolete by https://issues.guix.gnu.org/53336

--
Jacob Hrbek
diff mbox series

Patch

diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index fa88c91163..ddcfda17f5 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -466,7 +466,7 @@  (define-public libtorrent-rasterbar
 (define-public qbittorrent
   (package
     (name "qbittorrent")
-    (version "4.2.5")
+    (version "4.4.0")
     (source
      (origin
        (method git-fetch)