diff mbox series

[bug#53290,v2] gnu: Add emacs-fennel-mode.

Message ID 20220116104949.1618147-1-br@ndon.dk
State Accepted
Headers show
Series [bug#53290,v2] gnu: Add emacs-fennel-mode. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Brandon Jan. 16, 2022, 10:50 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-fennel-mode): New variable.
---

Thanks for the review. :) Here's a better commit.

 gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

--
2.34.0

Comments

Nicolas Goaziou Jan. 16, 2022, 10:37 p.m. UTC | #1
Hello,

Brandon Lucas <br@ndon.dk> writes:

> * gnu/packages/emacs-xyz.scm (emacs-fennel-mode): New variable.

Applied, thank you!

As a side note, it is usually a bad idea to add a new package at the end
of a file, because this location is likely to introduce merge conflicts.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c5cb07e16e..27b5c14fc5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -106,6 +106,7 @@ 
 ;;; Copyright © 2021 la snesne <lasnesne@lagunposprasihopre.org>
 ;;; Copyright © 2021 Brian Kubisiak <brian@kubisiak.com>
 ;;; Copyright © 2021, 2022 Taiju HIGASHI <higashi@taiju.info>
+;;; Copyright © 2022 Brandon Lucas <br@ndon.dk>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -29754,3 +29755,23 @@  (define-public emacs-global-tags
 wraps GNU Global calls and integration to editor using this API with
 project.el and xref.el.")
       (license license:gpl3+))))
+
+(define-public emacs-fennel-mode
+  (package
+    (name "emacs-fennel-mode")
+    (version "0.4.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.com/technomancy/fennel-mode")
+             (commit version)))
+       (sha256
+        (base32 "0dwas3ivhxdyw6njkcadc8c17cirq325cmby04qls8zkmrvlil1w"))))
+    (build-system emacs-build-system)
+    (home-page "https://gitlab.com/technomancy/fennel-mode")
+    (synopsis "Emacs major-mode for editing Fennel code")
+    (description
+     "Fennel mode provides font-lock, indentation, navigation, and REPL for
+ Fennel code within Emacs.")
+    (license license:gpl3+)))