diff mbox series

[bug#53290] gnu: Add emacs-fennel-mode.

Message ID 20220115215925.1542641-1-br@ndon.dk
State Accepted
Headers show
Series [bug#53290] gnu: Add emacs-fennel-mode. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Brandon Jan. 15, 2022, 10 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-fennel-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

--
2.34.0

Comments

Nicolas Goaziou Jan. 16, 2022, 9:17 a.m. UTC | #1
Hello,

Brandon Lucas <br@ndon.dk> writes:

> * gnu/packages/emacs-xyz.scm (emacs-fennel-mode): New variable.

Thank you for this. Some comments follow.

> +(define-public emacs-fennel-mode
> +  (let ((commit "54ed0792d0ac43a2d5db39741cf070c627368419")
> +        (revision "0"))
> +    (package
> +      (name "emacs-fennel-mode")
> +      (version (git-version "0.4.1" revision commit))

The commit hash you use matches the "0.4.1" version bump. Therefore you
can drop commit and revision binding, and use "0.4.1" in the version
field.

> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://gitlab.com/technomancy/fennel-mode.git")

You can drop the ".git" suffix here. I think "./pre-inst-env guix lint
emacs-fennel-mode" should warn you about it.

> +               (commit commit)))

Since you dropped commit binding, this should be (commit version)

> +      (description
> +       "Provides font-lock, indentation, navigation, and repl for Fennel code
> + within Emacs.")

Descriptions are expected to be full sentences. I suggest:

  Fennel mode provides font-lock, indentation, navigation and REPL for
  Fennel code within Emacs.

Could you send an updated patch?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c5cb07e16e..8175c48478 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -106,6 +106,7 @@ 
 ;;; Copyright © 2021 la snesne <lasnesne@lagunposprasihopre.org>
 ;;; Copyright © 2021 Brian Kubisiak <brian@kubisiak.com>
 ;;; Copyright © 2021, 2022 Taiju HIGASHI <higashi@taiju.info>
+;;; Copyright © 2022 Brandon Lucas <br@ndon.dk>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -29754,3 +29755,25 @@  (define-public emacs-global-tags
 wraps GNU Global calls and integration to editor using this API with
 project.el and xref.el.")
       (license license:gpl3+))))
+
+(define-public emacs-fennel-mode
+  (let ((commit "54ed0792d0ac43a2d5db39741cf070c627368419")
+        (revision "0"))
+    (package
+      (name "emacs-fennel-mode")
+      (version (git-version "0.4.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://gitlab.com/technomancy/fennel-mode.git")
+               (commit commit)))
+         (sha256
+          (base32 "0dwas3ivhxdyw6njkcadc8c17cirq325cmby04qls8zkmrvlil1w"))))
+      (build-system emacs-build-system)
+      (home-page "https://gitlab.com/technomancy/fennel-mode")
+      (synopsis "Emacs major-mode for editing Fennel code")
+      (description
+       "Provides font-lock, indentation, navigation, and repl for Fennel code
+ within Emacs.")
+      (license license:gpl3+))))