diff mbox series

[bug#51765,1/6] gnu: python-asdf: Update to 2.8.3

Message ID 20220114234025.18817-1-sharlatanus@gmail.com
State Accepted
Headers show
Series [bug#51765,1/6] gnu: python-asdf: Update to 2.8.3 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Jan. 14, 2022, 11:40 p.m. UTC
* gnu/packages/astronomy.scm: (python-asdf): Update to 2.8.3
  Refactor package style.
  [inputs]->[propagated-inputs]: To satisfy sanity checks of other
  packages depended on python-asdf. Add new input python-jmespath
---
 gnu/packages/astronomy.scm | 37 +++++++++++++++++++------------------
 1 file changed, 19 insertions(+), 18 deletions(-)

Comments

Vinicius Monego Jan. 30, 2022, 3:07 p.m. UTC | #1
Hi,

Em sex, 2022-01-14 às 23:40 +0000, Sharlatan Hellseher escreveu:
> * gnu/packages/astronomy.scm: (python-asdf): Update to 2.8.3
>   Refactor package style.
>   [inputs]->[propagated-inputs]: To satisfy sanity checks of other
>   packages depended on python-asdf. Add new input python-jmespath
> ---
>  gnu/packages/astronomy.scm | 37 +++++++++++++++++++-----------------
> -
>  1 file changed, 19 insertions(+), 18 deletions(-)
> 
> diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
> index a7a07fa3a8..f1392c55e3 100644
> --- a/gnu/packages/astronomy.scm
> +++ b/gnu/packages/astronomy.scm
> @@ -1269,34 +1269,35 @@ (define-public python-sep
>  (define-public python-asdf
>    (package
>      (name "python-asdf")
> -    (version "2.7.4")
> +    (version "2.8.3")
>      (source
>       (origin
>         (method url-fetch)
>         (uri (pypi-uri "asdf" version))
>         (sha256
> -        (base32
> "1mj52l2m8pbhiqacgjakjpvqi8kyx470yw151lcsswbq5wp0rsc6"))))
> +        (base32
> "0i4vq1hsympjgb1yvn4ql0gm8j1mki9ggmj03533kmg0nbzp03yy"))))
>      (build-system python-build-system)
>      (arguments
> -     ;; TODO: (Sharlatan-20210207T165820+0000): Tests depend on
> astropy, astropy
> -     ;; depends on asdf. Disable circular dependence.
> -     `(#:tests? #f))
> +     ;; NOTE: (Sharlatan-20211229T201059+0000): Tests depend on
> astropy and
> +     ;; gwcs, astropy gwcs depend on asdf. Disable circular
> dependence.
> +     (list #:tests? #f))
>      (native-inputs
> -     `(("packaging" ,python-packaging)
> -       ("semantic-version" ,python-semantic-version)
> -       ("setuptools-scm" ,python-setuptools-scm)))
> -     (inputs
> -      `(("importlib-resources" ,python-importlib-resources)
> -        ("jsonschema" ,python-jsonschema)
> -        ("numpy" ,python-numpy)
> -        ("pyyaml" ,python-pyyaml)))
> -     (home-page "https://github.com/asdf-format/asdf")
> -     (synopsis "Python tools to handle ASDF files")
> -     (description
> -      "The Advanced Scientific Data Format (ASDF) is a next-
> generation
> +     (list python-setuptools-scm
> +           python-semantic-version
> +           python-packaging))
> +    (propagated-inputs
> +     (list python-importlib-resources
> +           python-jsonschema
> +           python-jmespath
> +           python-numpy
> +           python-pyyaml))
> +    (home-page "https://github.com/asdf-format/asdf")
> +    (synopsis "Python tools to handle ASDF files")
> +    (description
> +     "The Advanced Scientific Data Format (ASDF) is a next-
> generation
>  interchange format for scientific data.  This package contains the
> Python
>  implementation of the ASDF Standard.")
> -     (license license:bsd-3)))
> +    (license license:bsd-3)))
>  
>  (define-public python-astroalign
>    (package

Ideally this change should be in two separate commits: one to propagate
inputs and another to update, but I'm going to leave this one as is for
this time.

I also made the following changes:

- Adjusted commit messages
- Set schema variables as non-public
- Changed descriptions
- Moved gwcs definition closer to the other variables
- Updated your copyright line
  
and pushed the whole series, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index a7a07fa3a8..f1392c55e3 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1269,34 +1269,35 @@  (define-public python-sep
 (define-public python-asdf
   (package
     (name "python-asdf")
-    (version "2.7.4")
+    (version "2.8.3")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "asdf" version))
        (sha256
-        (base32 "1mj52l2m8pbhiqacgjakjpvqi8kyx470yw151lcsswbq5wp0rsc6"))))
+        (base32 "0i4vq1hsympjgb1yvn4ql0gm8j1mki9ggmj03533kmg0nbzp03yy"))))
     (build-system python-build-system)
     (arguments
-     ;; TODO: (Sharlatan-20210207T165820+0000): Tests depend on astropy, astropy
-     ;; depends on asdf. Disable circular dependence.
-     `(#:tests? #f))
+     ;; NOTE: (Sharlatan-20211229T201059+0000): Tests depend on astropy and
+     ;; gwcs, astropy gwcs depend on asdf. Disable circular dependence.
+     (list #:tests? #f))
     (native-inputs
-     `(("packaging" ,python-packaging)
-       ("semantic-version" ,python-semantic-version)
-       ("setuptools-scm" ,python-setuptools-scm)))
-     (inputs
-      `(("importlib-resources" ,python-importlib-resources)
-        ("jsonschema" ,python-jsonschema)
-        ("numpy" ,python-numpy)
-        ("pyyaml" ,python-pyyaml)))
-     (home-page "https://github.com/asdf-format/asdf")
-     (synopsis "Python tools to handle ASDF files")
-     (description
-      "The Advanced Scientific Data Format (ASDF) is a next-generation
+     (list python-setuptools-scm
+           python-semantic-version
+           python-packaging))
+    (propagated-inputs
+     (list python-importlib-resources
+           python-jsonschema
+           python-jmespath
+           python-numpy
+           python-pyyaml))
+    (home-page "https://github.com/asdf-format/asdf")
+    (synopsis "Python tools to handle ASDF files")
+    (description
+     "The Advanced Scientific Data Format (ASDF) is a next-generation
 interchange format for scientific data.  This package contains the Python
 implementation of the ASDF Standard.")
-     (license license:bsd-3)))
+    (license license:bsd-3)))
 
 (define-public python-astroalign
   (package