diff mbox series

[bug#53190,4/5] gnu: python-requests-file: Update to 1.5.1.

Message ID 20220111162518.47475-4-monego@posteo.net
State Accepted
Headers show
Series Add python-zeep. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Jan. 11, 2022, 4:25 p.m. UTC
* gnu/packages/python-xyz.scm (python-requests-file): Update to 1.5.1.
[source]: Make some cosmetic changes.
[arguments]<#:phases>: Override 'check phase.
[home-page]: Don't break line.
---
 gnu/packages/python-xyz.scm | 15 ++++++++++-----
 1 file changed, 10 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d1127a072d..887b2f8579 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21713,19 +21713,24 @@  and corruption checks.")
 (define-public python-requests-file
   (package
     (name "python-requests-file")
-    (version "1.4.3")
+    (version "1.5.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "requests-file" version))
        (sha256
-        (base32
-         "1yp2jaxg3v86pia0q512dg3hz6s9y5vzdivsgrba1kds05ial14g"))))
+        (base32 "13kx4k83i9zcv20h0fnmawwwdzhcmw1z97mqib1h379qsc445mq7"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "python" "tests/test_requests_file.py")))))))
     (propagated-inputs
      (list python-requests python-six))
-    (home-page
-     "https://github.com/dashea/requests-file")
+    (home-page "https://github.com/dashea/requests-file")
     (synopsis "File transport adapter for Requests")
     (description
      "Requests-File is a transport adapter for use with the Requests Python