diff mbox series

[bug#53179,1/3] gnu: python-httpcore: Update to 0.13.7.

Message ID 20220111052429.34592-1-monego@posteo.net
State Accepted
Headers show
Series Update httpx and add pytest-httpx. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Jan. 11, 2022, 5:24 a.m. UTC
* gnu/packages/python-web.scm (python-httpcore): Update to 0.13.7.
[native-inputs]: Order alphabetically.
[propagated-inputs]: Add python-anyio.
---
 gnu/packages/ebook.scm      |  2 +-
 gnu/packages/python-web.scm | 17 ++++++++---------
 2 files changed, 9 insertions(+), 10 deletions(-)


base-commit: 9d613c36de1ea52e745d30bad841b6cdeaca65f4
diff mbox series

Patch

diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 03671ee902..5a02e79d1a 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -6,7 +6,7 @@ 
 ;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2021 la snesne <lasnesne@lagunposprasihopre.org>
 ;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 253b68e02c..ccce679933 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5030,20 +5030,19 @@  and serve updated contents upon changes to the directory.")
 (define-public python-httpcore
   (package
     (name "python-httpcore")
-    (version "0.12.2")
+    (version "0.13.7")
     (source
      (origin
-       ;; PyPI tarball does not contain tests.
-       (method git-fetch)
+       (method git-fetch)               ; no tests in PyPI
        (uri (git-reference
              (url "https://github.com/encode/httpcore")
-             (commit  version)))
+             (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1nrwwfdqjfc2a1k3j41cdwkprwvplf95fwmypdl2aq2qgp3209q0"))))
+        (base32 "1qf1kdscqs566qjzkxz9jxn0g30rx3s6jmxvizvc8q44m8rbs4gn"))))
     (build-system python-build-system)
     (arguments
-     `(#:tests? #f ; Tests hang at 98%
+     `(#:tests? #f                      ; Tests hang at 99%
        #:phases
        (modify-phases %standard-phases
          (replace 'check
@@ -5064,10 +5063,10 @@  and serve updated contents upon changes to the directory.")
            python-pytest-asyncio
            python-pytest-cov
            python-pytest-trio
-           python-uvicorn
-           python-trustme))
+           python-trustme
+           python-uvicorn))
     (propagated-inputs
-     (list python-h11 python-h2 python-sniffio python-trio
+     (list python-anyio python-h11 python-h2 python-sniffio python-trio
            python-trio-typing))
     (home-page "https://github.com/encode/httpcore")
     (synopsis "Minimal, low-level HTTP client")