diff mbox series

[bug#53128] gnu: Add font-cormorant.

Message ID 20220108192249.36103-1-philip@philipmcgrath.com
State Accepted
Headers show
Series [bug#53128] gnu: Add font-cormorant. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Philip McGrath Jan. 8, 2022, 7:22 p.m. UTC
Cormorant is a family of free fonts in the Garamond tradition.
The fonts are widely used, including in professionally-published
books, e.g. the German paperback edition of the works of Kazuo Ishiguro from
Heyne Verlag: https://fontsinuse.com/uses/19694/kazuo-ishiguro-heyne-verlag

 -Philip

* gnu/packages/fonts.scm (font-cormorant): New public variable.
---
 gnu/packages/fonts.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Ludovic Courtès Jan. 18, 2022, 9:52 p.m. UTC | #1
Hi,

Philip McGrath <philip@philipmcgrath.com> skribis:

> Cormorant is a family of free fonts in the Garamond tradition.
> The fonts are widely used, including in professionally-published
> books, e.g. the German paperback edition of the works of Kazuo Ishiguro from
> Heyne Verlag: https://fontsinuse.com/uses/19694/kazuo-ishiguro-heyne-verlag
>
>  -Philip
>
> * gnu/packages/fonts.scm (font-cormorant): New public variable.

Nice.  Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index df1446380f..63eb737750 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -42,6 +42,7 @@ 
 ;;; Copyright © 2021 Sergiu Ivanov <sivanov@colimite.fr>
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2288,3 +2289,33 @@  (define-public font-overpass
 Overpass includes proportional and monospace variants.")
     (license (list license:silofl1.1
                    license:lgpl2.1))))
+
+(define-public font-cormorant
+  (package
+    (name "font-cormorant")
+    (version "3.609")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/CatharsisFonts/Cormorant")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0fjp2xk4bjx8i6jamkyjq2fdr7324fh41pbn634iwnhdvvawvbav"))))
+    (build-system font-build-system)
+    (home-page "https://github.com/CatharsisFonts/Cormorant")
+    (synopsis
+     "Extravagant display serif typeface in the spirit of Garamond")
+    (description
+     "Cormorant is an extravagant display serif typeface inspired by
+the Garamond heritage.  The design goal of Cormorant was to distill
+the aesthetic essence of Garamond, unfetter it from the limitations of
+metal printing, and allow it to bloom into its natural refined form at
+high definition.  Cormorant is characterized by scandalously small
+counters, razor-sharp serifs, dangerously smooth curves, and
+flamboyantly tall accents.  While many implementations of Garamond at
+small optical sizes already exist, Cormorant aims for the sparsely
+populated niche of display-size counterparts that exploit the high
+resolution of contemporary screens and print media to the fullest.")
+    (license license:silofl1.1)))