diff mbox series

[bug#53055,v2] gnu: Add emacs-ox-gfm.

Message ID 20220106152145.30290-1-higashi@taiju.info
State Accepted
Headers show
Series [bug#53055,v2] gnu: Add emacs-ox-gfm. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Taiju HIGASHI Jan. 6, 2022, 3:21 p.m. UTC
---
 gnu/packages/emacs-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Taiju HIGASHI Jan. 6, 2022, 3:26 p.m. UTC | #1
I'm sorry. The encoding of the previous email was wrong, so I resent it.
Taiju HIGASHI Jan. 6, 2022, 3:36 p.m. UTC | #2
If you have any problems with my copyright statement for the 2021 version, you can delete it.
I forgot to write it in the patch below, so I added it.

https://issues.guix.gnu.org/51950

Thanks
Nicolas Goaziou Jan. 7, 2022, 8:18 p.m. UTC | #3
Hello,

Taiju HIGASHI <higashi@taiju.info> writes:

> +(define-public emacs-ox-gfm

I applied your patch with a proper commit message.

> +    (description "This package is a small exporter based on the Markdown exporter already existing in Org mode. It should support the Github flavored markdown features.")

I also added two spaces at the end of the first sentence.

Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ac25286c08..658d97e169 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -105,6 +105,7 @@ 
 ;;; Copyright © 2021 Simon South <simon@simonsouth.net>
 ;;; Copyright © 2021 la snesne <lasnesne@lagunposprasihopre.org>
 ;;; Copyright © 2021 Brian Kubisiak <brian@kubisiak.com>
+;;; Copyright © 2021, 2022 Taiju HIGASHI <higashi@taiju.info>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -7953,6 +7954,24 @@  (define-public emacs-org-cv
 may export to Markdown so that it can be used for a web based CV.")
       (license license:gpl3+))))
 
+(define-public emacs-ox-gfm
+  (package
+    (name "emacs-ox-gfm")
+    (version "1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/larstvei/ox-gfm")
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32
+                "0drdypmgxk3238hmkqw9s3cw9wv94cyfqar5ar0bv0k69s92pxj8"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/larstvei/ox-gfm")
+    (synopsis "Github Flavored Markdown Back-End for Org Export Engine")
+    (description "This package is a small exporter based on the Markdown exporter already existing in Org mode. It should support the Github flavored markdown features.")
+    (license license:gpl3+)))
+
 (define-public emacs-2048-game
   (package
     (name "emacs-2048-game")