diff mbox series

[bug#53054,2/3] gnu: python-msgpack-transitional: Fix broken tests.

Message ID 20220106143359.11750-2-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#53054,1/3] gnu: python-os-testr: Add python-testrepository to inputs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Tanguy LE CARROUR Jan. 6, 2022, 2:33 p.m. UTC
* gnu/packages/python-xyz.scm (python-msgpack-transitional)[arguments]:
Replace references to deprecated Python methods.
---
 gnu/packages/python-xyz.scm | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Leo Famulari Jan. 11, 2022, 7:51 p.m. UTC | #1
On Thu, Jan 06, 2022 at 03:33:58PM +0100, Tanguy Le Carrour wrote:
> * gnu/packages/python-xyz.scm (python-msgpack-transitional)[arguments]:
> Replace references to deprecated Python methods.

Thanks for taking care of this package. I saw that this patch was
applied as commit d07d3ea008d24f8ad5f4f32f86cb1f89226123ae.

Are you using this package? It has no uses within Guix, so we could
remove it.
Tanguy LE CARROUR Jan. 12, 2022, 8:10 a.m. UTC | #2
Hi Leo,


Quoting Leo Famulari (2022-01-11 20:51:15)
> On Thu, Jan 06, 2022 at 03:33:58PM +0100, Tanguy Le Carrour wrote:
> > * gnu/packages/python-xyz.scm (python-msgpack-transitional)[arguments]:
> > Replace references to deprecated Python methods.
> 
> Thanks for taking care of this package. I saw that this patch was
> applied as commit d07d3ea008d24f8ad5f4f32f86cb1f89226123ae.
> 
> Are you using this package? It has no uses within Guix, so we could
> remove it.

I was supposed to removed it, indeed!
But, apparently, I messed up the patch set! :-(

The thing is, in the bug report, there's a mention to the patch set I
was supposed to push as a v2, but I don't know where it comes from if
the v2 was not actually sent?!

```
>   gnu: python-os-testr: Add python-testrepository to inputs.
>   gnu: poetry: Fix package inputs.
>   gnu: python-msgpack-transitional: Remove unused variable.
```

Unfortunatly, Ludo applied it already! My bad!

… I'll fix my mess and push the fix. Sorry guys! :-(
Leo Famulari Jan. 12, 2022, 6:35 p.m. UTC | #3
On Wed, Jan 12, 2022 at 09:10:28AM +0100, Tanguy LE CARROUR wrote:
> … I'll fix my mess and push the fix. Sorry guys! :-(

No worries, I removed it in commit d5ae6739fdb4786c49d33de3fec9872c73d2e311

And I removed python2-msgpack in the subsequent commit.
Tanguy LE CARROUR Jan. 13, 2022, 8:02 a.m. UTC | #4
Hi Leo,


Quoting Leo Famulari (2022-01-12 19:35:51)
> On Wed, Jan 12, 2022 at 09:10:28AM +0100, Tanguy LE CARROUR wrote:
> > … I'll fix my mess and push the fix. Sorry guys! :-(
> 
> No worries, I removed it in commit d5ae6739fdb4786c49d33de3fec9872c73d2e311
> 
> And I removed python2-msgpack in the subsequent commit.

Thanks!
Tanguy LE CARROUR Jan. 13, 2022, 9:51 a.m. UTC | #5
Hi Leo,


Quoting Tanguy LE CARROUR (2022-01-12 09:10:28)
> Quoting Leo Famulari (2022-01-11 20:51:15)
> > On Thu, Jan 06, 2022 at 03:33:58PM +0100, Tanguy Le Carrour wrote:
> > > * gnu/packages/python-xyz.scm (python-msgpack-transitional)[arguments]:
> > > Replace references to deprecated Python methods.
> > 
> > Thanks for taking care of this package. I saw that this patch was
> > applied as commit d07d3ea008d24f8ad5f4f32f86cb1f89226123ae.
> > 
> > Are you using this package? It has no uses within Guix, so we could
> > remove it.
> 
> I was supposed to removed it, indeed!
> But, apparently, I messed up the patch set! :-(
> 
> The thing is, in the bug report, there's a mention to the patch set I
> was supposed to push as a v2, but I don't know where it comes from if
> the v2 was not actually sent?!
> 
> ```
> >   gnu: python-os-testr: Add python-testrepository to inputs.
> >   gnu: poetry: Fix package inputs.
> >   gnu: python-msgpack-transitional: Remove unused variable.
> ```
> 
> Unfortunatly, Ludo applied it already! My bad!
> 
> … I'll fix my mess and push the fix. Sorry guys! :-(

I've submitted a patch set (#53228) to, I hope, fix my mess!

I'm closing this one.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bea33cbf05..40c9e30969 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10688,6 +10688,11 @@  (define-public python-msgpack-transitional
                (substitute* "setup.py"
                  (("TRANSITIONAL = False")
                    "TRANSITIONAL = 1"))
+               ;; This old version is not compatible with Python 3.9
+               (substitute* '("test/test_buffer.py" "test/test_extension.py")
+                 ((".tostring\\(") ".tobytes("))
+               (substitute* '("test/test_buffer.py" "test/test_extension.py")
+                 ((".fromstring\\(") ".frombytes("))
                #t))))))))
 
 (define-public python2-msgpack