diff mbox series

[bug#53049] gnu: libaio: Fix cross-compilation.

Message ID 20220106123030.128feae4@tachikoma.lepiller.eu
State Accepted
Headers show
Series [bug#53049] gnu: libaio: Fix cross-compilation. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Julien Lepiller Jan. 6, 2022, 11:30 a.m. UTC
Hi Guix!

I saw a message on the unofficial #guix:matrix.org room about libaio
failing to build. Indeed, it uses %output and that doesn't exist in
cross-compilation context anymore. Here's a small patch to fix that. I
had to be careful not to change the package outside of
cross-compilation, since it has >5000 dependents, hence the ,(if ...)
statement.

Comments

Ludovic Courtès Jan. 8, 2022, 9:57 p.m. UTC | #1
Hi,

Julien Lepiller <julien@lepiller.eu> skribis:

>>From 160572309d022b4249cb41296864a0e1c32eae0a Mon Sep 17 00:00:00 2001
> Message-Id: <160572309d022b4249cb41296864a0e1c32eae0a.1641468451.git.julien@lepiller.eu>
> From: Julien Lepiller <julien@lepiller.eu>
> Date: Thu, 6 Jan 2022 11:48:16 +0100
> Subject: [PATCH] gnu: libaio: Fix cross-compilation.
>
> * gnu/packages/linux.scm (libaio)[arguments]: Do not use singular
> %output.

LGTM!  (You could add a TODO stating it should be homogenized on the
next rebuild cycle.)

Thanks,
Ludo’.
Tobias Geerinckx-Rice Jan. 8, 2022, 10:14 p.m. UTC | #2
Hi,

Julien Lepiller wrote:
> Subject: [PATCH] gnu: libaio: Fix cross-compilation.

I pushed a series of cross-compilation fixes yesterday night to 
fix the pinebook-pro image build ASAP.

It was pretty bad: there was no valid CI build, so the 
guix.gnu.org ‘Download’ was just… broken.  I didn't notice your 
patch.

Mine looks slightly different (preferring as I do shiny gexps, and 
trying to move away from %output{s,} :-) but the thrust is the 
same, comment included.

Thanks! and closing,

T G-R
Mathieu Othacehe Jan. 9, 2022, 9:43 a.m. UTC | #3
Hello Tobias,

> It was pretty bad: there was no valid CI build, so the guix.gnu.org ‘Download’
> was just… broken.  I didn't notice your patch.
>
> Mine looks slightly different (preferring as I do shiny gexps, and trying to
> move away from %output{s,} :-) but the thrust is the same, comment included.

We now have 100% coverage on the "images" specifications[1], thanks for
fixing that :).

Mathieu

[1]: https://ci.guix.gnu.org/jobset/images
diff mbox series

Patch

From 160572309d022b4249cb41296864a0e1c32eae0a Mon Sep 17 00:00:00 2001
Message-Id: <160572309d022b4249cb41296864a0e1c32eae0a.1641468451.git.julien@lepiller.eu>
From: Julien Lepiller <julien@lepiller.eu>
Date: Thu, 6 Jan 2022 11:48:16 +0100
Subject: [PATCH] gnu: libaio: Fix cross-compilation.

* gnu/packages/linux.scm (libaio)[arguments]: Do not use singular
%output.
---
 gnu/packages/linux.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3daad494e1..438ced6a27 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5225,7 +5225,9 @@  (define-public libaio
     (arguments
      `(#:make-flags
        (let ((target ,(%current-target-system)))
-         (list (string-append "prefix=" %output)
+         (list (string-append "prefix=" ,(if (%current-target-system)
+                                             `(assoc-ref %outputs "out")
+                                             '%output))
                (string-append
                 "CC=" (if target
                           (string-append (assoc-ref %build-inputs "cross-gcc")
-- 
2.34.0