diff mbox series

[bug#53022,v2] gnu: python-urwidtrees: Add python-mock to inputs.

Message ID 20220105101328.28509-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#53022,v2] gnu: python-urwidtrees: Add python-mock to inputs. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Tanguy LE CARROUR Jan. 5, 2022, 10:13 a.m. UTC
* gnu/packages/python-xyz.scm (python-urwidtrees)[native-inputs]: Add
python-mock.
---
 gnu/packages/python-xyz.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Leo Famulari Jan. 5, 2022, 11:11 p.m. UTC | #1
On Wed, Jan 05, 2022 at 11:13:28AM +0100, Tanguy Le Carrour wrote:
> * gnu/packages/python-xyz.scm (python-urwidtrees)[native-inputs]: Add
> python-mock.

Thanks! I explained the rationale for the change in the commit message
and pushed as c468db2e567e17418e4b0e214856056bcfee85a8
Tanguy LE CARROUR Jan. 6, 2022, 7:59 a.m. UTC | #2
Hi Leo,


Quoting Leo Famulari (2022-01-06 00:11:49)
> On Wed, Jan 05, 2022 at 11:13:28AM +0100, Tanguy Le Carrour wrote:
> > * gnu/packages/python-xyz.scm (python-urwidtrees)[native-inputs]: Add
> > python-mock.
> 
> Thanks!

Thanks!


> I explained the rationale for the change in the commit message

*OUPS*, sorry, I had never done that before. I'll keep it in mind for
next time! :-)

Regards
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e04b4f973f..fff2f06835 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -65,7 +65,7 @@ 
 ;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
 ;;; Copyright © 2019, 2020, 2021 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
-;;; Copyright © 2019, 2020, 2021 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2019, 2020, 2021, 2022 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2019, 2021 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
 ;;; Copyright © 2020 Riku Viitanen <riku.viitanen@protonmail.com>
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
@@ -8893,6 +8893,7 @@  (define-public python-urwidtrees
     (arguments
      '(#:tests? #f)) ; no tests
     (propagated-inputs (list python-urwid))
+    (native-inputs (list python-mock))
     (home-page "https://github.com/pazz/urwidtrees")
     (synopsis "Tree widgets for urwid")
     (description "Urwidtrees is a Widget Container API for the @code{urwid}