diff mbox series

[bug#53007] gnu: networking: Add arp-scan

Message ID 20220104153415.5822-1-manolis837@gmail.com
State Accepted
Headers show
Series [bug#53007] gnu: networking: Add arp-scan | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Manolis Ragkousis Jan. 4, 2022, 3:34 p.m. UTC
From: Manolis Ragkousis <manolis837@gmail.com>

* gnu/packages/networking.scm (arp-scan): New variable.
---
 gnu/packages/networking.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Manolis Ragkousis Jan. 4, 2022, 3:40 p.m. UTC | #1
This is the correct version. :)

On Tue, 4 Jan 2022, 17:34 , <manolis837@gmail.com> wrote:

> From: Manolis Ragkousis <manolis837@gmail.com>
>
> * gnu/packages/networking.scm (arp-scan): New variable.
> ---
>  gnu/packages/networking.scm | 30 ++++++++++++++++++++++++++++++
>  1 file changed, 30 insertions(+)
>
> diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
> index cc9cc61164..ac67d58541 100644
> --- a/gnu/packages/networking.scm
> +++ b/gnu/packages/networking.scm
> @@ -47,6 +47,7 @@
>  ;;; Copyright © 2021 Milkey Mouse <milkeymouse@meme.institute>
>  ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
>  ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
> +;;; Copyright © 2022 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -4143,3 +4144,32 @@ (define-public putty
>  implementations.")
>      (home-page "https://www.chiark.greenend.org.uk/~sgtatham/putty/")
>      (license license:expat)))
> +
> +(define-public arp-scan
> +  (package
> +    (name "arp-scan")
> +    (version "1.9.7")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://github.com/royhills/arp-scan/"
> +                           "archive/refs/tags/" version ".tar.gz"))
> +       (sha256
> +        (base32 "0ff0c43rw1b4cm52rx7s6q0wsix3ahjjfhd8wk85nr9wjgj3cg70"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (replace 'bootstrap
> +           (lambda _
> +             (invoke "autoreconf" "-vfi"))))))
> +    (inputs
> +     (list libpcap))
> +    (native-inputs
> +     (list autoconf automake libtool pkg-config))
> +    (propagated-inputs
> +     (list perl-libwww))
> +    (home-page "https://github.com/royhills/arp-scan")
> +    (synopsis "Dscover and fingerprint IP hosts on the local network
> using ARP")
> +    (description "A tool that uses ARP to discover and fingerprint IP
> hosts on the local network")
> +    (license license:gpl3)))
> --
> 2.33.1
>
>
Manolis Ragkousis Jan. 6, 2022, 11:18 a.m. UTC | #2
Did anyone have some time to check this?

On 1/4/22 17:40, Manolis Ragkousis wrote:
> This is the correct version. :)
> 
> On Tue, 4 Jan 2022, 17:34 , <manolis837@gmail.com 
> <mailto:manolis837@gmail.com>> wrote:
> 
>     From: Manolis Ragkousis <manolis837@gmail.com
>     <mailto:manolis837@gmail.com>>
> 
>     * gnu/packages/networking.scm (arp-scan): New variable.
>     ---
>       gnu/packages/networking.scm | 30 ++++++++++++++++++++++++++++++
>       1 file changed, 30 insertions(+)
> 
>     diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
>     index cc9cc61164..ac67d58541 100644
>     --- a/gnu/packages/networking.scm
>     +++ b/gnu/packages/networking.scm
>     @@ -47,6 +47,7 @@
>       ;;; Copyright © 2021 Milkey Mouse <milkeymouse@meme.institute>
>       ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net
>     <mailto:glv@posteo.net>>
>       ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be
>     <mailto:maximedevos@telenet.be>>
>     +;;; Copyright © 2022 Manolis Fragkiskos Ragkousis
>     <manolis837@gmail.com <mailto:manolis837@gmail.com>>
>       ;;;
>       ;;; This file is part of GNU Guix.
>       ;;;
>     @@ -4143,3 +4144,32 @@ (define-public putty
>       implementations.")
>           (home-page
>     "https://www.chiark.greenend.org.uk/~sgtatham/putty/
>     <https://www.chiark.greenend.org.uk/~sgtatham/putty/>")
>           (license license:expat)))
>     +
>     +(define-public arp-scan
>     +  (package
>     +    (name "arp-scan")
>     +    (version "1.9.7")
>     +    (source
>     +     (origin
>     +       (method url-fetch)
>     +       (uri (string-append "https://github.com/royhills/arp-scan/
>     <https://github.com/royhills/arp-scan/>"
>     +                           "archive/refs/tags/" version ".tar.gz"))
>     +       (sha256
>     +        (base32
>     "0ff0c43rw1b4cm52rx7s6q0wsix3ahjjfhd8wk85nr9wjgj3cg70"))))
>     +    (build-system gnu-build-system)
>     +    (arguments
>     +     `(#:phases
>     +       (modify-phases %standard-phases
>     +         (replace 'bootstrap
>     +           (lambda _
>     +             (invoke "autoreconf" "-vfi"))))))
>     +    (inputs
>     +     (list libpcap))
>     +    (native-inputs
>     +     (list autoconf automake libtool pkg-config))
>     +    (propagated-inputs
>     +     (list perl-libwww))
>     +    (home-page "https://github.com/royhills/arp-scan
>     <https://github.com/royhills/arp-scan>")
>     +    (synopsis "Dscover and fingerprint IP hosts on the local
>     network using ARP")
>     +    (description "A tool that uses ARP to discover and fingerprint
>     IP hosts on the local network")
>     +    (license license:gpl3)))
>     -- 
>     2.33.1
>
Leo Famulari Jan. 11, 2022, 6:54 p.m. UTC | #3
Thanks for the patch!

On Tue, Jan 04, 2022 at 05:34:15PM +0200, manolis837@gmail.com wrote:
> +    (version "1.9.7")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://github.com/royhills/arp-scan/"
> +                           "archive/refs/tags/" version ".tar.gz"))

This type of tarball is automatically generated by Git / Github based on
the Git tag. However, whenever Github updates their software, the
generated tarballs may change, invalidating our hash. [0]

For that reason, we either use tarballs created by the upstream
developers, or the git-fetch method. For this program, the developers
stopped making tarballs after version 1.9, so we have to use git-fetch
to package 1.9.7.

> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (replace 'bootstrap
> +           (lambda _
> +             (invoke "autoreconf" "-vfi"))))))

The bootstrap phase of gnu-build-system runs autoreconf when 'configure'
is missing. I'm guessing this package was written before
gnu-build-system learned to do that, because the package does build
successfully without this replacement.

> +    (inputs
> +     (list libpcap))
> +    (native-inputs
> +     (list autoconf automake libtool pkg-config))
> +    (propagated-inputs
> +     (list perl-libwww))
> +    (home-page "https://github.com/royhills/arp-scan")
> +    (synopsis "Dscover and fingerprint IP hosts on the local network using ARP")
                  ^
Typo here --------|

> +    (description "A tool that uses ARP to discover and fingerprint IP hosts on the local network")

Descriptions should be written in "complete" sentences. How about the
following?

"Arp-scan is a tool that uses ARP to discover and fingerprint IP hosts
on the local network."

> +    (license license:gpl3)))

The source headers of 'arp-scan.c' say that the program can be
distributed "either version 3 of the License, or (at your option) any
later version." So I think it's gpl3+.

Can you send a revised patch?

[0] https://github.com/libgit2/libgit2/issues/4343
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index cc9cc61164..ac67d58541 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -47,6 +47,7 @@ 
 ;;; Copyright © 2021 Milkey Mouse <milkeymouse@meme.institute>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4143,3 +4144,32 @@  (define-public putty
 implementations.")
     (home-page "https://www.chiark.greenend.org.uk/~sgtatham/putty/")
     (license license:expat)))
+
+(define-public arp-scan
+  (package
+    (name "arp-scan")
+    (version "1.9.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/royhills/arp-scan/"
+                           "archive/refs/tags/" version ".tar.gz"))
+       (sha256
+        (base32 "0ff0c43rw1b4cm52rx7s6q0wsix3ahjjfhd8wk85nr9wjgj3cg70"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'bootstrap
+           (lambda _
+             (invoke "autoreconf" "-vfi"))))))
+    (inputs
+     (list libpcap))
+    (native-inputs
+     (list autoconf automake libtool pkg-config))
+    (propagated-inputs
+     (list perl-libwww))
+    (home-page "https://github.com/royhills/arp-scan")
+    (synopsis "Dscover and fingerprint IP hosts on the local network using ARP")
+    (description "A tool that uses ARP to discover and fingerprint IP hosts on the local network")
+    (license license:gpl3)))