diff mbox series

[bug#53006] gnu: networking: Add arp-scan

Message ID 20220104152609.4928-1-manolis837@gmail.com
State Accepted
Headers show
Series [bug#53006] gnu: networking: Add arp-scan | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/applying patch success View Laminar job
cbaines/git branch success View Git branch
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Manolis Ragkousis Jan. 4, 2022, 3:26 p.m. UTC
From: Manolis Ragkousis <manolis837@gmail.com>

* gnu/packages/networking.scm (arp-scan): New variable.
---
 gnu/packages/networking.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Manolis Ragkousis Jan. 4, 2022, 3:27 p.m. UTC | #1
Everyone, sorry this is the wrong patch. I sent the previous version
by mistake. Will send the correct one shortly. Ignore this.

On Tue, 4 Jan 2022 at 17:26, <manolis837@gmail.com> wrote:
>
> From: Manolis Ragkousis <manolis837@gmail.com>
>
> * gnu/packages/networking.scm (arp-scan): New variable.
> ---
>  gnu/packages/networking.scm | 21 +++++++++++++++++++++
>  1 file changed, 21 insertions(+)
>
> diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
> index cc9cc61164..7bcd513e41 100644
> --- a/gnu/packages/networking.scm
> +++ b/gnu/packages/networking.scm
> @@ -4143,3 +4143,24 @@ (define-public putty
>  implementations.")
>      (home-page "https://www.chiark.greenend.org.uk/~sgtatham/putty/")
>      (license license:expat)))
> +
> +(define-public arp-scan
> +  (package
> +    (name "arp-scan")
> +    (version "1.9")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       ;; https://github.com/royhills/arp-scan/releases/download/1.9/arp-scan-1.9.tar.gz
> +       (uri (string-append "https://github.com/royhills/arp-scan/"
> +                           "releases/download/" version "/"
> +                           name "-" version ".tar.gz"))
> +       (sha256
> +        (base32 "14nqjzbmnlx2nac7lwa93y5m5iqk3layakyxyvfmvs283k3qm46f"))))
> +    (build-system gnu-build-system)
> +    (inputs
> +     `(("libpcap" ,libpcap)))
> +    (home-page "https://github.com/royhills/arp-scan")
> +    (synopsis "Dscover and fingerprint IP hosts on the local network using ARP")
> +    (description "A tool that uses ARP to discover and fingerprint IP hosts on the local network")
> +    (license license:gpl3)))
> --
> 2.33.1
>
Manolis Ragkousis Jan. 4, 2022, 3:32 p.m. UTC | #2
Please close I sent the wrong patch.

On Tue, 4 Jan 2022 at 17:27, Manolis Ragkousis <manolis837@gmail.com> wrote:
>
> Everyone, sorry this is the wrong patch. I sent the previous version
> by mistake. Will send the correct one shortly. Ignore this.
>
> On Tue, 4 Jan 2022 at 17:26, <manolis837@gmail.com> wrote:
> >
> > From: Manolis Ragkousis <manolis837@gmail.com>
> >
> > * gnu/packages/networking.scm (arp-scan): New variable.
> > ---
> >  gnu/packages/networking.scm | 21 +++++++++++++++++++++
> >  1 file changed, 21 insertions(+)
> >
> > diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
> > index cc9cc61164..7bcd513e41 100644
> > --- a/gnu/packages/networking.scm
> > +++ b/gnu/packages/networking.scm
> > @@ -4143,3 +4143,24 @@ (define-public putty
> >  implementations.")
> >      (home-page "https://www.chiark.greenend.org.uk/~sgtatham/putty/")
> >      (license license:expat)))
> > +
> > +(define-public arp-scan
> > +  (package
> > +    (name "arp-scan")
> > +    (version "1.9")
> > +    (source
> > +     (origin
> > +       (method url-fetch)
> > +       ;; https://github.com/royhills/arp-scan/releases/download/1.9/arp-scan-1.9.tar.gz
> > +       (uri (string-append "https://github.com/royhills/arp-scan/"
> > +                           "releases/download/" version "/"
> > +                           name "-" version ".tar.gz"))
> > +       (sha256
> > +        (base32 "14nqjzbmnlx2nac7lwa93y5m5iqk3layakyxyvfmvs283k3qm46f"))))
> > +    (build-system gnu-build-system)
> > +    (inputs
> > +     `(("libpcap" ,libpcap)))
> > +    (home-page "https://github.com/royhills/arp-scan")
> > +    (synopsis "Dscover and fingerprint IP hosts on the local network using ARP")
> > +    (description "A tool that uses ARP to discover and fingerprint IP hosts on the local network")
> > +    (license license:gpl3)))
> > --
> > 2.33.1
> >
Manolis Ragkousis Jan. 4, 2022, 3:40 p.m. UTC | #3
On Tue, 4 Jan 2022, 17:32 Manolis Ragkousis, <manolis837@gmail.com> wrote:

> Please close I sent the wrong patch.
>
> On Tue, 4 Jan 2022 at 17:27, Manolis Ragkousis <manolis837@gmail.com>
> wrote:
> >
> > Everyone, sorry this is the wrong patch. I sent the previous version
> > by mistake. Will send the correct one shortly. Ignore this.
> >
> > On Tue, 4 Jan 2022 at 17:26, <manolis837@gmail.com> wrote:
> > >
> > > From: Manolis Ragkousis <manolis837@gmail.com>
> > >
> > > * gnu/packages/networking.scm (arp-scan): New variable.
> > > ---
> > >  gnu/packages/networking.scm | 21 +++++++++++++++++++++
> > >  1 file changed, 21 insertions(+)
> > >
> > > diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
> > > index cc9cc61164..7bcd513e41 100644
> > > --- a/gnu/packages/networking.scm
> > > +++ b/gnu/packages/networking.scm
> > > @@ -4143,3 +4143,24 @@ (define-public putty
> > >  implementations.")
> > >      (home-page "https://www.chiark.greenend.org.uk/~sgtatham/putty/")
> > >      (license license:expat)))
> > > +
> > > +(define-public arp-scan
> > > +  (package
> > > +    (name "arp-scan")
> > > +    (version "1.9")
> > > +    (source
> > > +     (origin
> > > +       (method url-fetch)
> > > +       ;;
> https://github.com/royhills/arp-scan/releases/download/1.9/arp-scan-1.9.tar.gz
> > > +       (uri (string-append "https://github.com/royhills/arp-scan/"
> > > +                           "releases/download/" version "/"
> > > +                           name "-" version ".tar.gz"))
> > > +       (sha256
> > > +        (base32
> "14nqjzbmnlx2nac7lwa93y5m5iqk3layakyxyvfmvs283k3qm46f"))))
> > > +    (build-system gnu-build-system)
> > > +    (inputs
> > > +     `(("libpcap" ,libpcap)))
> > > +    (home-page "https://github.com/royhills/arp-scan")
> > > +    (synopsis "Dscover and fingerprint IP hosts on the local network
> using ARP")
> > > +    (description "A tool that uses ARP to discover and fingerprint IP
> hosts on the local network")
> > > +    (license license:gpl3)))
> > > --
> > > 2.33.1
> > >
>
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index cc9cc61164..7bcd513e41 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4143,3 +4143,24 @@  (define-public putty
 implementations.")
     (home-page "https://www.chiark.greenend.org.uk/~sgtatham/putty/")
     (license license:expat)))
+
+(define-public arp-scan
+  (package
+    (name "arp-scan")
+    (version "1.9")
+    (source
+     (origin
+       (method url-fetch)
+       ;; https://github.com/royhills/arp-scan/releases/download/1.9/arp-scan-1.9.tar.gz
+       (uri (string-append "https://github.com/royhills/arp-scan/"
+                           "releases/download/" version "/"
+                           name "-" version ".tar.gz"))
+       (sha256
+        (base32 "14nqjzbmnlx2nac7lwa93y5m5iqk3layakyxyvfmvs283k3qm46f"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("libpcap" ,libpcap)))
+    (home-page "https://github.com/royhills/arp-scan")
+    (synopsis "Dscover and fingerprint IP hosts on the local network using ARP")
+    (description "A tool that uses ARP to discover and fingerprint IP hosts on the local network")
+    (license license:gpl3)))