diff mbox series

[bug#52997] gnu: Add python-facebook-sdk.

Message ID 20220104003003.861-1-goodoldpaul@autistici.org
State New
Headers show
Series [bug#52997] gnu: Add python-facebook-sdk. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

paul Jan. 4, 2022, 12:30 a.m. UTC
* gnu/packages/python-web.scm (python-facebook-sdk): New variable.
---
 gnu/packages/python-web.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)


base-commit: 0c5a58e34d894b95d94c61aae0525a01fa18ecd2

Comments

paul Jan. 24, 2022, 5:22 p.m. UTC | #1
This is a friendly ping :)

Thank you for your time and efforts
paul March 5, 2022, 11:27 p.m. UTC | #2
Dear all,

this is just a ping, thank you for your time and efforts . I'm attaching 
an updated patchset.

paul
ashish.is--- via Guix-patches" via July 1, 2022, 9:43 p.m. UTC | #3
Dear all,
this is a friendly ping :) . I'm sending an updated patch.


Thank you for your time and effort,

giacomo
ashish.is--- via Guix-patches" via April 12, 2023, 9:29 p.m. UTC | #4
Dear all,
this is a friendly ping :) . I'm sending an updated patch.

Thank you for your time and effort,

  giacomo
ashish.is--- via Guix-patches" via April 12, 2023, 9:49 p.m. UTC | #5
Dear all,
this is a friendly ping :) . I'm sending an updated patchset.

Thank you for your time and effort,

  giacomo
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index bc7e21ca85..90193590dd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6264,3 +6264,32 @@  (define-public python-mwparserfromhell
 Full documentation may be found at
 @uref{https://mwparserfromhell.readthedocs.io, ReadTheDocs}")
     (license license:expat)))
+
+(define-public python-facebook-sdk
+  (package
+    (name "python-facebook-sdk")
+    (version "3.1.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri
+         (git-reference
+          (url "https://github.com/mobolic/facebook-sdk")
+          (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "0p7p0wvcspd9p8d6r25bgjbf0ihdw5g1jw3dylwngrazdmc3g36b"))))
+    (build-system python-build-system)
+    (arguments
+     ;; Tests require network access.
+     `(#:tests? #f))
+    (propagated-inputs `(("python-requests" ,python-requests)))
+    (home-page "https://facebook-sdk.readthedocs.io")
+    (synopsis
+      "Facebook Graph API client in Python")
+    (description
+      "This client library is designed to support the Facebook Graph API and
+the official Facebook JavaScript SDK, which is the canonical way to implement
+Facebook authentication.")
+    (license license:asl2.0)))