diff mbox series

[bug#52938] gnu: freegish: Fix build with GCC 10.

Message ID 20220101221708.105652-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#52938] gnu: freegish: Fix build with GCC 10. | expand

Commit Message

Felix Gruber Jan. 1, 2022, 10:17 p.m. UTC
* gnu/packages/games.scm (freegish): Update to latest commit that
  includes a fix for the GCC 10 build-failure.
---
 gnu/packages/games.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Leo Famulari Jan. 2, 2022, 3:55 a.m. UTC | #1
On Sat, Jan 01, 2022 at 10:17:08PM +0000, Felix Gruber wrote:
> * gnu/packages/games.scm (freegish): Update to latest commit that
>   includes a fix for the GCC 10 build-failure.

Thanks! I tweaked the commit message and pushed as
6f83a503af908fdd732765e1327c6afb8f53f3d2

This package should be changed to use the git-version procedure instead
of using string-append to create the version, but that's not a pressing
matter.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3e6cdf4514..d4653c912e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5962,8 +5962,8 @@  Magic, Egypt, Indians, Norsemen, Persian or Romans.")
     (license license:gpl2+)))
 
 (define-public freegish
-  (let ((commit "8795cd7adc95957883f2d3465eb9036a774667a7")
-        (revision "1"))
+  (let ((commit "21977ee5fc2008231b35160df00efe954c508b16")
+        (revision "2"))
     (package
       (name "freegish")
       (version (string-append "0-" revision "." (string-take commit 9)))
@@ -5975,7 +5975,7 @@  Magic, Egypt, Indians, Norsemen, Persian or Romans.")
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "1p1zf5qqagmcpi1db2bs02cnalpy3qiymp6yzan7k1bhmv859gsx"))
+                  "1qh0gcnbyxyzmb13jifwba4xrzj94m4w9whdvl0gnds6ricmwply"))
                 (modules '((guix build utils)))
                 ;; The audio files in the "music" directory are licensed under
                 ;; CC-BY-NC, so we delete them.