diff mbox series

[bug#52933] gnu: widelands: Fix build against boost 1.77.

Message ID 20220101183414.101071-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#52933] gnu: widelands: Fix build against boost 1.77. | expand

Commit Message

Felix Gruber Jan. 1, 2022, 6:34 p.m. UTC
Widelands fails to build with boost 1.77 due to a missing include in one
of Wideland's header files that was previously indirectly included by
boost 1.76.

* gnu/packages/games.scm (widelands)[source]: Add patch.
* gnu/packages/patches/widelands-add-missing-map-include.patch: New
  file.
* gnu/local.mk (dist_patch_DATA): Add it.
---
 gnu/local.mk                                  |  1 +
 gnu/packages/games.scm                        |  5 ++--
 .../widelands-add-missing-map-include.patch   | 28 +++++++++++++++++++
 3 files changed, 32 insertions(+), 2 deletions(-)
 create mode 100644 gnu/packages/patches/widelands-add-missing-map-include.patch

Comments

Leo Famulari Jan. 2, 2022, 4:24 a.m. UTC | #1
On Sat, Jan 01, 2022 at 06:34:14PM +0000, Felix Gruber wrote:
> Widelands fails to build with boost 1.77 due to a missing include in one
> of Wideland's header files that was previously indirectly included by
> boost 1.76.
> 
> * gnu/packages/games.scm (widelands)[source]: Add patch.
> * gnu/packages/patches/widelands-add-missing-map-include.patch: New
>   file.
> * gnu/local.mk (dist_patch_DATA): Add it.

Thanks! Pushed as a83dc5022b70d4ee96741311553c65bc636625ae
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index e14bd47b95..c3ecafb149 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1927,6 +1927,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/wicd-get-selected-profile-fix.patch	\
   %D%/packages/patches/wicd-urwid-1.3.patch			\
   %D%/packages/patches/wicd-wpa2-ttls.patch			\
+  %D%/packages/patches/widelands-add-missing-map-include.patch	\
   %D%/packages/patches/widelands-system-wide_minizip.patch	\
   %D%/packages/patches/wmctrl-64-fix.patch			\
   %D%/packages/patches/wmfire-update-for-new-gdk-versions.patch	\
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3e6cdf4514..36b15dfa66 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -61,7 +61,7 @@ 
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2021 David Pflug <david@pflug.io>
-;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
 ;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
 ;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
@@ -5135,7 +5135,8 @@  tactics.")
        (patches
         ;; Use system Minizip.  Patch is provided by Debian, and discussed
         ;; upstream at <https://github.com/widelands/widelands/issues/399>.
-        (search-patches "widelands-system-wide_minizip.patch"))))
+        (search-patches "widelands-system-wide_minizip.patch"
+                        "widelands-add-missing-map-include.patch"))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags
diff --git a/gnu/packages/patches/widelands-add-missing-map-include.patch b/gnu/packages/patches/widelands-add-missing-map-include.patch
new file mode 100644
index 0000000000..633731bea2
--- /dev/null
+++ b/gnu/packages/patches/widelands-add-missing-map-include.patch
@@ -0,0 +1,28 @@ 
+From 316eaea209754368a57f445ea4dd016ecf8eded6 Mon Sep 17 00:00:00 2001
+From: matthiakl <t-m.42@mailpost.spdns.org>
+Date: Sat, 14 Aug 2021 19:24:08 +0200
+Subject: [PATCH] Added missing direct incude (#5025)
+
+---
+This patch is from
+https://github.com/widelands/widelands/pull/5025
+which has been merged after the release of Widelands 1.0.
+
+ src/network/bufferedconnection.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/network/bufferedconnection.h b/src/network/bufferedconnection.h
+index fe974b9e..7e1ecf87 100644
+--- a/src/network/bufferedconnection.h
++++ b/src/network/bufferedconnection.h
+@@ -20,6 +20,7 @@
+ #ifndef WL_NETWORK_BUFFEREDCONNECTION_H
+ #define WL_NETWORK_BUFFEREDCONNECTION_H
+ 
++#include <map>
+ #include <memory>
+ #include <mutex>
+ #include <thread>
+-- 
+2.30.2
+