diff mbox series

[bug#52900] gnu: libfido2: install udev rules

Message ID 20211230170032.20683-1-igaryhe@gmail.com
State Accepted
Headers show
Series [bug#52900] gnu: libfido2: install udev rules | expand

Commit Message

dan Dec. 30, 2021, 5 p.m. UTC
[arguments]: Add a configure flag specifying the installation directory of the
udev rule.

---
 gnu/packages/security-token.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

dan Dec. 30, 2021, 5:12 p.m. UTC | #1
For some reason the cover letter was not shown up properly.  The 
following is the missing line:

* gnu/packages/security-token.scm(libfido2): Install udev rules.
John Kehayias June 15, 2022, 4:13 p.m. UTC | #2
Hello,

Thanks for the patch. Could you update it to match the current package definition of libfido2 (and you may want to add your copyright line to the top)?

Since libu2f is deprecated, we should rely on libfido2, so we need the udev rules that this patch makes available. I tested a local version which just needed to add the (string-append...) s-expression to the #:configure-flags that are currently present. I tested that it built and did have the udev rules.

Thanks!
John
diff mbox series

Patch

diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 6a3e2d9179..719515e3ea 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -777,7 +777,9 @@  (define-public libfido2
        ("openssl" ,openssl)))
     (build-system cmake-build-system)
     (arguments
-     '(#:phases
+     '(#:configure-flags
+       (list (string-append "-DUDEV_RULES_DIR=" %output "/lib/udev/rules.d"))
+       #:phases
        (modify-phases %standard-phases
          ;; regress tests enabled only for debug builds
          (delete 'check))))