diff mbox series

[bug#51838,v7,39/41] gnu: Add node-serialport-parser-byte-length.

Message ID 20211230074456.33433-40-philip@philipmcgrath.com
State Accepted
Headers show
Series guix: node-build-system: Support compiling add-ons with node-gyp. | expand

Commit Message

Philip McGrath Dec. 30, 2021, 7:44 a.m. UTC
* gnu/packages/node-xyz.scm (node-serialport-parser-byte-length): New
variable.
---
 gnu/packages/node-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index e6e25f036a..fa9498e31e 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1215,3 +1215,25 @@  (define-public node-serialport-parser-cctalk
 messages.  This package provides @code{CCTalk}, which emits packets for the
 ccTalk protocol (an open standard for currency detectors) as they are
 received.")))
+
+(define-public node-serialport-parser-byte-length
+  (package
+    (inherit node-serialport-binding-abstract)
+    (name "node-serialport-parser-byte-length")
+    (version "9.2.4")
+    (inputs `())
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda args
+             (chdir "packages/parser-byte-length"))))
+       #:tests? #f))
+    (synopsis "Node SerialPort parser for fixed-length buffers")
+    (description "Node SerialPort is a modular suite of Node.js packages for
+accessing serial ports.  The Guix package @code{node-serialport} provides the
+recommended high-level interface.
+
+Parsers are used to take raw binary data and transform them into usable
+messages.  This package provides @code{ByteLength}, a parser that emits data
+as a buffer every time a specified number of bytes are received.")))