diff mbox series

[bug#51838,v7,16/41] gnu: node-irc-colors: Use #:absent-dependencies.

Message ID 20211230074456.33433-17-philip@philipmcgrath.com
State Accepted
Headers show
Series guix: node-build-system: Support compiling add-ons with node-gyp. | expand

Commit Message

Philip McGrath Dec. 30, 2021, 7:44 a.m. UTC
gnu/packages/node-xyz.scm (node-irc-colors)[arguments]: Add
`#:absent-dependencies`. Stop deleting the `'configure` phase.
---
 gnu/packages/node-xyz.scm | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 9e602fd0e8..6c3811528a 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -366,12 +366,10 @@  (define-public node-irc-colors
                 "0q3y34rbnlc55jcakmdxkicwazyvyph9r6gaf6hi8k7wj2nfwfli"))))
     (build-system node-build-system)
     (arguments
-     '(#:tests? #f                      ; FIXME: tests depend on node-istanbul
-       #:phases
-       (modify-phases %standard-phases
-         ;; The default configure phase fails due to various packages
-         ;; being missing, as we don't have them packaged yet.
-         (delete 'configure))))
+     '(#:absent-dependencies
+       `("istanbul"
+         "vows")
+       #:tests? #f))
     (home-page "https://github.com/fent/irc-colors.js")
     (synopsis "Node.js module providing color and formatting for IRC")
     (description "@code{node-irc-colors} is a Node.js module that