diff mbox series

[bug#51838,v7,12/41] gnu: node-llparse-bootstrap: Use #:absent-dependencies.

Message ID 20211230074456.33433-13-philip@philipmcgrath.com
State Accepted
Headers show
Series guix: node-build-system: Support compiling add-ons with node-gyp. | expand

Commit Message

Philip McGrath Dec. 30, 2021, 7:44 a.m. UTC
gnu/packages/node.scm (node-llparse-bootstrap)[arguments]: Add
`#:absent-dependencies`. Stop deleting the `'configure` phase.
---
 gnu/packages/node.scm | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 4d3db6a8ea..f952119a9f 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -613,9 +613,18 @@  (define-public node-llparse-bootstrap
     (arguments
      `(#:node ,node-bootstrap
        #:tests? #f
+       #:absent-dependencies
+       `("@types/debug"
+         "@types/mocha"
+         "@types/node"
+         "esm"
+         "llparse-test-fixture"
+         "mocha"
+         "ts-node"
+         "tslint"
+         "typescript")
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure)
          (replace 'build
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((esbuild (search-input-file inputs "/bin/esbuild")))