diff mbox series

[bug#52857,3/3] gnu: python-hy: Honor #:tests? flag.

Message ID 20211228193335.74580-3-monego@posteo.net
State Accepted
Headers show
Series Fix build of python-funcparserlib and python-hy. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Dec. 28, 2021, 7:33 p.m. UTC
* gnu/packages/python-xyz.scm (python-hy)[arguments]: Adjust custom 'check
phase to honor the #:tests? flag.
---
 gnu/packages/python-xyz.scm | 13 +++++++------
 1 file changed, 7 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9b651d2108..316549ecf1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13022,12 +13022,13 @@  with a new public API, and RPython support.")
      '(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             (invoke "python" "-m" "pytest" "-k"
-                     (string-append     ; skip some failed tests
-                      "not test_bin_hy_sys_executable"
-                      " and not test_bin_hy_circular_macro_require"
-                      " and not test_macro_from_module")))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "python" "-m" "pytest" "-k"
+                       (string-append   ; skip some failed tests
+                        "not test_bin_hy_sys_executable"
+                        " and not test_bin_hy_circular_macro_require"
+                        " and not test_macro_from_module"))))))))
     (native-inputs
      (list python-pytest))
     (propagated-inputs