diff mbox series

[bug#52850] gnu: Add openxr.

Message ID 20211228141702.62910-1-monego@posteo.net
State Accepted
Headers show
Series [bug#52850] gnu: Add openxr. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Dec. 28, 2021, 2:17 p.m. UTC
* gnu/packages/graphics.scm (openxr): New variable.
---
 gnu/packages/graphics.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)


base-commit: 28b477cb2e5d9185da16f305caff15809dfa06f3

Comments

Nicolas Goaziou Dec. 29, 2021, 11:05 p.m. UTC | #1
Hello,

Vinicius Monego <monego@posteo.net> writes:

> * gnu/packages/graphics.scm (openxr): New variable.

Applied. Thank you.

> +       (snippet
> +        '(begin
> +           ;; Delete bundled jsoncpp.
> +           (delete-file-recursively "src/external/jsoncpp") #t))

I removed the trailing #t here.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 3be37d7841..5c7ae8831e 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -96,6 +96,7 @@ 
   #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages sdl)
+  #:use-module (gnu packages serialization)
   #:use-module (gnu packages stb)
   #:use-module (gnu packages swig)
   #:use-module (gnu packages tbb)
@@ -1919,6 +1920,38 @@  Some feature highlights:
 @end itemize\n")
       (license license:gpl3+))))
 
+(define-public openxr
+  (package
+    (name "openxr")
+    (version "1.0.20")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/KhronosGroup/OpenXR-SDK")
+             (commit (string-append "release-" version))))
+       (file-name (git-file-name name version))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           ;; Delete bundled jsoncpp.
+           (delete-file-recursively "src/external/jsoncpp") #t))
+       (sha256
+        (base32 "1jd7jjxlrdi8kjnmn3sad7dgb4h48dbxryfb9snf0kifn47bi20m"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f))                    ; there are no tests
+    (native-inputs
+     (list pkg-config python shaderc vulkan-headers))
+    (inputs
+     (list jsoncpp mesa vulkan-loader wayland))
+    (home-page "https://www.khronos.org/openxr/")
+    (synopsis "Generated headers and sources for OpenXR loader")
+    (description "This package contains OpenXR headers, as well as source code
+and build scripts for the OpenXR loader.")
+    ;; Dual licensed.  Either license applies.
+    (license (list license:asl2.0 license:expat))))
+
 (define-public monado
   (package
     (name "monado")