diff mbox series

[bug#52149] feat(gnu packages rust): Add 'rust-1.57'; Change 'rust' to 'rust-1.57'

Message ID 20211226144842.4136-1-paren@disroot.org
State Accepted
Headers show
Series [bug#52149] feat(gnu packages rust): Add 'rust-1.57'; Change 'rust' to 'rust-1.57' | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

\( Dec. 26, 2021, 2:48 p.m. UTC
---
 gnu/packages/rust.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Comments

Efraim Flashner Dec. 27, 2021, 12:16 p.m. UTC | #1
On Sun, Dec 26, 2021 at 02:48:42PM +0000, (unmatched-parenthesis via Guix-patches via wrote:
> ---
>  gnu/packages/rust.scm | 6 +++++-
>  1 file changed, 5 insertions(+), 1 deletion(-)
> 
> diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
> index a07a86763e..524a558777 100644
> --- a/gnu/packages/rust.scm
> +++ b/gnu/packages/rust.scm
> @@ -780,8 +780,12 @@ (define rust-1.56
>    (rust-bootstrapped-package
>     rust-1.55 "1.56.1" "04cmqx7nn63hzz7z27b2b0dj2qx18rck9ifvip43s6dampx8v2f3"))
>  
> +(define rust-1.57
> +  (rust-bootstrapped-package
> +   rust-1.56 "1.57.0" "06jw8ka2p3kls8p0gd4p0chhhb1ia1mlvj96zn78n7qvp71zjiim"))
> +
>  ;;; Note: Only the latest versions of Rust are supported and tested.  The
>  ;;; intermediate rusts are built for bootstrapping purposes and should not
>  ;;; be relied upon.  This is to ease maintenance and reduce the time
>  ;;; required to build the full Rust bootstrap chain.
> -(define-public rust rust-1.54)
> +(define-public rust rust-1.57)
> -- 
> 2.34.0
> 

I removed the part about updating rust to 1.57. I made the three new
rust- variables public, so that they can be used easily with the #:rust
keyword.

I'm leaving the bug open so you can work on the other patches you
attached before.
\( Dec. 27, 2021, 3:29 p.m. UTC | #2
~/code/clones/guix $ 
/gnu/store/5lc2cfxszksmak1hhb7d1bj6cz0wzxj7-rust-cargo-0.58.0/bin/cargo 
--version
cargo 1.57.0

the patches will be coming in shortly :D

(cargo's versioning scheme is a little weird; the binary seems to have 
+1 major version and -1 minor version compared to the crate on 
crates.io; see https://lib.rs/crates/cargo. this is the case with 
guix's current cargo too:

~/code/clones/guix $ cargo --version
cargo 1.52.0

so don't be alarmed by the 1.57.0 :))
Maxim Cournoyer Jan. 17, 2022, 5:07 p.m. UTC | #3
Hi!

Efraim Flashner <efraim@flashner.co.il> writes:

> On Sun, Dec 26, 2021 at 02:48:42PM +0000, (unmatched-parenthesis via Guix-patches via wrote:
>> ---
>>  gnu/packages/rust.scm | 6 +++++-
>>  1 file changed, 5 insertions(+), 1 deletion(-)
>> 
>> diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
>> index a07a86763e..524a558777 100644
>> --- a/gnu/packages/rust.scm
>> +++ b/gnu/packages/rust.scm
>> @@ -780,8 +780,12 @@ (define rust-1.56
>>    (rust-bootstrapped-package
>>     rust-1.55 "1.56.1" "04cmqx7nn63hzz7z27b2b0dj2qx18rck9ifvip43s6dampx8v2f3"))
>>  
>> +(define rust-1.57
>> +  (rust-bootstrapped-package
>> +   rust-1.56 "1.57.0" "06jw8ka2p3kls8p0gd4p0chhhb1ia1mlvj96zn78n7qvp71zjiim"))
>> +
>>  ;;; Note: Only the latest versions of Rust are supported and tested.  The
>>  ;;; intermediate rusts are built for bootstrapping purposes and should not
>>  ;;; be relied upon.  This is to ease maintenance and reduce the time
>>  ;;; required to build the full Rust bootstrap chain.
>> -(define-public rust rust-1.54)
>> +(define-public rust rust-1.57)
>> -- 
>> 2.34.0
>> 
>
> I removed the part about updating rust to 1.57. I made the three new
> rust- variables public, so that they can be used easily with the #:rust
> keyword.
>
> I'm leaving the bug open so you can work on the other patches you
> attached before.

With the version-1.4.0 branch merged, the default rust used is now 1.57.
Were there other patches remaining to apply here?  If so, could you
rebase them and send them again?  In any case, let us know!

Thank you,

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index a07a86763e..524a558777 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -780,8 +780,12 @@  (define rust-1.56
   (rust-bootstrapped-package
    rust-1.55 "1.56.1" "04cmqx7nn63hzz7z27b2b0dj2qx18rck9ifvip43s6dampx8v2f3"))
 
+(define rust-1.57
+  (rust-bootstrapped-package
+   rust-1.56 "1.57.0" "06jw8ka2p3kls8p0gd4p0chhhb1ia1mlvj96zn78n7qvp71zjiim"))
+
 ;;; Note: Only the latest versions of Rust are supported and tested.  The
 ;;; intermediate rusts are built for bootstrapping purposes and should not
 ;;; be relied upon.  This is to ease maintenance and reduce the time
 ;;; required to build the full Rust bootstrap chain.
-(define-public rust rust-1.54)
+(define-public rust rust-1.57)