diff mbox series

[bug#52757] gnu: sdl2: Update to 2.0.18.

Message ID 20211223165956.28448-1-igaryhe@gmail.com
State Accepted
Headers show
Series [bug#52757] gnu: sdl2: Update to 2.0.18. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

dan Dec. 23, 2021, 4:59 p.m. UTC
* gnu/packages/sdl.scm(sdl2): Update to 2.0.18.

[inputs]: Update with new syntax.

---
 gnu/packages/sdl.scm | 27 +++++++++++++++------------
 1 file changed, 15 insertions(+), 12 deletions(-)

Comments

Nicolas Goaziou Jan. 25, 2022, 5:56 p.m. UTC | #1
Hello,

dan <igaryhe@gmail.com> writes:

> * gnu/packages/sdl.scm(sdl2): Update to 2.0.18.
> [inputs]: Update with new syntax.

Thank you.

I applied it on core-updates branch.

> -     (append `(("dbus" ,dbus)
> -               ("eudev" ,eudev) ; for discovering input devices
> -               ("fcitx" ,fcitx) ; helps with CJK input
> -               ("glib" ,glib)
> -               ("ibus" ,ibus)
> -               ("libxkbcommon" ,libxkbcommon)
> -               ("libxcursor" ,libxcursor) ; enables X11 cursor support
> -               ("wayland" ,wayland)
> -               ("wayland-protocols" ,wayland-protocols))
> -             (package-inputs sdl)))
> +     (list dbus
> +           eudev      ; for discovering input devices
> +           fcitx      ; helps with CJK input
> +           glib
> +           ibus
> +           libxkbcommon
> +           libxcursor ; enables X11 cursor support
> +           wayland
> +           wayland-protocols
> +           libxrandr
> +           glu
> +           alsa-lib
> +           pulseaudio))

I used the modify-inputs macros instead.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 4c38e2f055..071697c125 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -113,7 +113,7 @@  (define-public sdl
 (define-public sdl2
   (package (inherit sdl)
     (name "sdl2")
-    (version "2.0.14")
+    (version "2.0.18")
     (source (origin
              (method url-fetch)
              (uri
@@ -121,7 +121,7 @@  (define-public sdl2
                              version ".tar.gz"))
              (sha256
               (base32
-               "1g1jahknv5r4yhh1xq5sf0md20ybdw1zh1i15lry26sq39bmn8fq"))))
+               "073iwmggkvvl82fssqb7xzbb4awraprjig6zxav0p8dz7pbhrm4l"))))
     (arguments
      (substitute-keyword-arguments (package-arguments sdl)
        ((#:configure-flags flags)
@@ -141,16 +141,19 @@  (define-public sdl2
      ;; experience a bug where input events are doubled.
      ;;
      ;; For more information, see: https://dev.solus-project.com/T1721
-     (append `(("dbus" ,dbus)
-               ("eudev" ,eudev) ; for discovering input devices
-               ("fcitx" ,fcitx) ; helps with CJK input
-               ("glib" ,glib)
-               ("ibus" ,ibus)
-               ("libxkbcommon" ,libxkbcommon)
-               ("libxcursor" ,libxcursor) ; enables X11 cursor support
-               ("wayland" ,wayland)
-               ("wayland-protocols" ,wayland-protocols))
-             (package-inputs sdl)))
+     (list dbus
+           eudev      ; for discovering input devices
+           fcitx      ; helps with CJK input
+           glib
+           ibus
+           libxkbcommon
+           libxcursor ; enables X11 cursor support
+           wayland
+           wayland-protocols
+           libxrandr
+           glu
+           alsa-lib
+           pulseaudio))
     (license license:bsd-3)))
 
 (define-public libmikmod