diff mbox series

[bug#52738] gnu: Add poweralertd

Message ID 20211222175135.8490-1-dev@jpoiret.xyz
State Accepted
Headers show
Series [bug#52738] gnu: Add poweralertd | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Josselin Poiret Dec. 22, 2021, 5:51 p.m. UTC
* gnu/packages/freedesktop.scm (poweralertd): Add variable.
---
 gnu/packages/freedesktop.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Xinglu Chen Dec. 23, 2021, 11:11 a.m. UTC | #1
Hi,

Josselin Poiret schrieb am Mittwoch der 22. Dezember 2021 um 18:51 +01:

> * gnu/packages/freedesktop.scm (poweralertd): Add variable.
> ---
>  gnu/packages/freedesktop.scm | 27 +++++++++++++++++++++++++++
>  1 file changed, 27 insertions(+)
>
> diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
> index dcd1870e41..896f8e2847 100644
> --- a/gnu/packages/freedesktop.scm
> +++ b/gnu/packages/freedesktop.scm
> @@ -2429,6 +2429,33 @@ (define-public xdg-desktop-portal-wlr
>  compositors.")
>      (license license:expat)))
>  
> +(define-public poweralertd
> +  (package
> +    (name "poweralertd")
> +    (version "0.2.0")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://git.sr.ht/~kennylevinsen/poweralertd")
> +             (commit version)))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "19rw9q4pcqw56nmzjfglfikzx5wwjl4n08awwdhg0jy1k0bm3dvp"))))
> +    (build-system meson-build-system)
> +    (arguments
> +     '(#:configure-flags '("-Dman-pages=enabled")))
> +    (native-inputs
> +     (list scdoc pkg-config bash-minimal))
> +    (inputs
> +     (list elogind))
> +    (home-page "https://git.sr.ht/~kennylevinsen/poweralertd")

Nitpick: <https://sr.ht/~kennylevinsen/poweralertd> seems more
appropriate since it also contains links to the ML and bug tracker.

> +    (synopsis "Power alert daemon")
> +    (description "poweralertd is a daemon that watches for UPower events and
> +notifies the user using any notification daemon implementing
> +@code{org.freedesktop.Notifications}.")
> +    (license license:gpl3)))

The LICENSE file doesn’t mention “only v3”, so it should probably be
‘gpl3+’.

Otherwise, LGTM!

--8<---------------cut here---------------start------------->8---
Result of running `guix review 20211222175135.8490-1-dev@jpoiret.xyz -D': (still a WIP)

  Successfully built 1 out of 1 package(s).

  No lint warnings were emitted
--8<---------------cut here---------------end--------------->8---
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index dcd1870e41..896f8e2847 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2429,6 +2429,33 @@  (define-public xdg-desktop-portal-wlr
 compositors.")
     (license license:expat)))
 
+(define-public poweralertd
+  (package
+    (name "poweralertd")
+    (version "0.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~kennylevinsen/poweralertd")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "19rw9q4pcqw56nmzjfglfikzx5wwjl4n08awwdhg0jy1k0bm3dvp"))))
+    (build-system meson-build-system)
+    (arguments
+     '(#:configure-flags '("-Dman-pages=enabled")))
+    (native-inputs
+     (list scdoc pkg-config bash-minimal))
+    (inputs
+     (list elogind))
+    (home-page "https://git.sr.ht/~kennylevinsen/poweralertd")
+    (synopsis "Power alert daemon")
+    (description "poweralertd is a daemon that watches for UPower events and
+notifies the user using any notification daemon implementing
+@code{org.freedesktop.Notifications}.")
+    (license license:gpl3)))
+
 (define-public waypipe
   (package
     (name "waypipe")