diff mbox series

[bug#52730] gnu: gst-plugins/selection: Make #:configure-flags optional.

Message ID 20211222033442.14793-1-jackhill@jackhill.us
State New
Headers show
Series [bug#52730] gnu: gst-plugins/selection: Make #:configure-flags optional. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jack Hill Dec. 22, 2021, 3:34 a.m. UTC
* gnu/packages/gstreamer.scm (gst-plugins/selection): Provide the empyt list
as a default value for #:configure-flags.
---
 gnu/packages/gstreamer.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Liliana Marie Prikler Dec. 24, 2021, 12:44 a.m. UTC | #1
Hi,

Am Dienstag, dem 21.12.2021 um 22:34 -0500 schrieb Jack Hill:
> * gnu/packages/gstreamer.scm (gst-plugins/selection): Provide the
> empyt list as a default value for #:configure-flags.
The current implementation ought to copy pre-existing configure-flags
as-is if you don't supply flags on your own.  I personally believe
that's preferable over an empty value, that will probably be reset. 
WDYT?
Jack Hill Dec. 24, 2021, 5:17 a.m. UTC | #2
On Fri, 24 Dec 2021, Liliana Marie Prikler wrote:

> Hi,
>
> Am Dienstag, dem 21.12.2021 um 22:34 -0500 schrieb Jack Hill:
>> * gnu/packages/gstreamer.scm (gst-plugins/selection): Provide the
>> empyt list as a default value for #:configure-flags.

> The current implementation ought to copy pre-existing configure-flags
> as-is if you don't supply flags on your own.  I personally believe
> that's preferable over an empty value, that will probably be reset.
> WDYT?

Yes, I agree that the current implementation ought to, but it doesn't. 
Instead it complains:

"""
ice-9/psyntax.scm:2794:12: In procedure syntax-violation:
Syntax error:
unknown location: quote: bad syntax in form quote
"""

I'll see about a v2.

Thanks!
Jack
Jack Hill Dec. 24, 2021, 6:37 a.m. UTC | #3
On Fri, 24 Dec 2021, Jack Hill wrote:

>
>
> On Fri, 24 Dec 2021, Liliana Marie Prikler wrote:
>
>> Hi,
>> 
>> Am Dienstag, dem 21.12.2021 um 22:34 -0500 schrieb Jack Hill:
>>> * gnu/packages/gstreamer.scm (gst-plugins/selection): Provide the
>>> empyt list as a default value for #:configure-flags.
>
>> The current implementation ought to copy pre-existing configure-flags
>> as-is if you don't supply flags on your own.  I personally believe
>> that's preferable over an empty value, that will probably be reset.
>> WDYT?
>
> Yes, I agree that the current implementation ought to, but it doesn't. 
> Instead it complains:
>
> """
> ice-9/psyntax.scm:2794:12: In procedure syntax-violation:
> Syntax error:
> unknown location: quote: bad syntax in form quote
> """
>
> I'll see about a v2.

I've looked at it for a little bit now, but I'm afraid that I'm stuck. I 
tried setting the default to #f (which may have been happening implicitly 
anyway):

```
(define-public gst-plugins/selection
   (lambda* (pkg #:key plugins (configure-flags #f))
     "Build PKG with only PLUGINS enabled.  Optionally, if CONFIGURE-FLAGS are
given, also pass them to the build system instead of the ones used by PKG."
     (package/inherit pkg
       (arguments
        (substitute-keyword-arguments (package-arguments pkg)
          ((#:configure-flags flags `(,@(or configure-flags '())))
           `(append
             (list
              ,@(map (lambda (plugin)
                       (string-append "-D" plugin "=enabled"))
                     plugins))
             (list ,@(or configure-flags flags))))
           ((#:phases phases)
            `(modify-phases ,phases
               (add-after 'unpack 'disable-auto-plugins
                 (lambda _
                   (substitute* "meson_options.txt"
                     (("'auto'") "'disabled'")))))))))))
```

but that still gives me the "bad syntax in form quote" message. I can keep 
thinking about it, but if someone else knows the solution, I'd be happy to 
learn from you :)

Best,
Jack
Liliana Marie Prikler Dec. 24, 2021, 7:56 a.m. UTC | #4
Hi Jack,

Am Freitag, dem 24.12.2021 um 01:37 -0500 schrieb Jack Hill:
> On Fri, 24 Dec 2021, Jack Hill wrote:
> 
> I've looked at it for a little bit now, but I'm afraid that I'm
> stuck. I tried setting the default to #f (which may have been
> happening implicitly anyway):
Yes, if you don't supply an optional argument in Guile (or I guess in
Scheme generally), that argument gets #f as value.

> ```
> (define-public gst-plugins/selection
>    (lambda* (pkg #:key plugins (configure-flags #f))
>      "Build PKG with only PLUGINS enabled.  Optionally, if CONFIGURE-
> FLAGS are
> given, also pass them to the build system instead of the ones used by
> PKG."
>      (package/inherit pkg
>        (arguments
>         (substitute-keyword-arguments (package-arguments pkg)
>           ((#:configure-flags flags `(,@(or configure-flags '())))
>            `(append
>              (list
>               ,@(map (lambda (plugin)
>                        (string-append "-D" plugin "=enabled"))
>                      plugins))
>              (list ,@(or configure-flags flags))))
>            ((#:phases phases)
>             `(modify-phases ,phases
>                (add-after 'unpack 'disable-auto-plugins
>                  (lambda _
>                    (substitute* "meson_options.txt"
>                      (("'auto'") "'disabled'")))))))))))
> ```
> 
> but that still gives me the "bad syntax in form quote" message. I can
> keep thinking about it, but if someone else knows the solution, I'd
> be happy to learn from you :)
I swear this used to work before the c-u-f merge.  There might be a
problem mixing this with gexps or something I didn't account for back
then.
Liliana Marie Prikler Aug. 16, 2022, 7:46 p.m. UTC | #5
Hi Jack,

Am Freitag, dem 24.12.2021 um 00:17 -0500 schrieb Jack Hill:
> On Fri, 24 Dec 2021, Liliana Marie Prikler wrote:
> 
> > Hi,
> > 
> > Am Dienstag, dem 21.12.2021 um 22:34 -0500 schrieb Jack Hill:
> > > * gnu/packages/gstreamer.scm (gst-plugins/selection): Provide the
> > > empyt list as a default value for #:configure-flags.
> 
> > The current implementation ought to copy pre-existing configure-
> > flags
> > as-is if you don't supply flags on your own.  I personally believe
> > that's preferable over an empty value, that will probably be reset.
> > WDYT?
> 
> Yes, I agree that the current implementation ought to, but it
> doesn't. 
> Instead it complains:
> 
> """
> ice-9/psyntax.scm:2794:12: In procedure syntax-violation:
> Syntax error:
> unknown location: quote: bad syntax in form quote
> """
Is this still an issue?  Also try staging, which has gstreamer 1.20 and
some gexp-improvements for gst-plugins/selection.

Cheers
Maxim Cournoyer Jan. 22, 2024, 4:36 p.m. UTC | #6
Hello Jack,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Hi Jack,
>
> Am Freitag, dem 24.12.2021 um 00:17 -0500 schrieb Jack Hill:
>> On Fri, 24 Dec 2021, Liliana Marie Prikler wrote:
>> 
>> > Hi,
>> > 
>> > Am Dienstag, dem 21.12.2021 um 22:34 -0500 schrieb Jack Hill:
>> > > * gnu/packages/gstreamer.scm (gst-plugins/selection): Provide the
>> > > empyt list as a default value for #:configure-flags.
>> 
>> > The current implementation ought to copy pre-existing configure-
>> > flags
>> > as-is if you don't supply flags on your own.  I personally believe
>> > that's preferable over an empty value, that will probably be reset.
>> > WDYT?
>> 
>> Yes, I agree that the current implementation ought to, but it
>> doesn't. 
>> Instead it complains:
>> 
>> """
>> ice-9/psyntax.scm:2794:12: In procedure syntax-violation:
>> Syntax error:
>> unknown location: quote: bad syntax in form quote
>> """
> Is this still an issue?  Also try staging, which has gstreamer 1.20 and
> some gexp-improvements for gst-plugins/selection.

Ping :-)
diff mbox series

Patch

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 87adb7c92a..1f6a56e30d 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -1034,7 +1034,7 @@  (define-public gst-editing-services
     (license license:gpl2+)))
 
 (define-public gst-plugins/selection
-  (lambda* (pkg #:key plugins configure-flags)
+  (lambda* (pkg #:key plugins (configure-flags '()))
     "Build PKG with only PLUGINS enabled.  Optionally, if CONFIGURE-FLAGS are
 given, also pass them to the build system instead of the ones used by PKG."
     (package/inherit pkg