diff mbox series

[bug#52710,1/2] gnu: Add guile-lzma.

Message ID 20211221183948.2314-1-samplet@ngyro.com
State Accepted
Headers show
Series Update Disarchive | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Timothy Sample Dec. 21, 2021, 6:39 p.m. UTC
* gnu/packages/guile.scm (guile-lzma): New variable.
---
 gnu/packages/guile.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Mathieu Othacehe Dec. 22, 2021, 9:58 a.m. UTC | #1
Hello Timothy,

> +    (native-inputs
> +     `(("autoconf" ,autoconf)
> +       ("automake" ,automake)
> +       ("guile" ,guile-3.0)
> +       ("guile-bytestructures" ,guile-bytestructures)
> +       ("pkg-config" ,pkg-config)))
> +    (inputs
> +     `(("guile" ,guile-3.0)
> +       ("xz" ,xz)))
> +    (propagated-inputs
> +     `(("guile-bytestructures" ,guile-bytestructures)))

You should update those to fit the new style.

Otherwise looks fine!

Thanks,

Mathieu
Timothy Sample Dec. 22, 2021, 6:49 p.m. UTC | #2
Hi Mathieu,

Mathieu Othacehe <othacehe@gnu.org> writes:

> Hello Timothy,
>
>> +    (native-inputs
>> +     `(("autoconf" ,autoconf)
>> +       ("automake" ,automake)
>> +       ("guile" ,guile-3.0)
>> +       ("guile-bytestructures" ,guile-bytestructures)
>> +       ("pkg-config" ,pkg-config)))
>> +    (inputs
>> +     `(("guile" ,guile-3.0)
>> +       ("xz" ,xz)))
>> +    (propagated-inputs
>> +     `(("guile-bytestructures" ,guile-bytestructures)))
>
> You should update those to fit the new style.

Of course!  Old habits....  :)

> Otherwise looks fine!
>
> Thanks,

Pushed.  Thank you!


-- Tim
diff mbox series

Patch

diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 28887dd69f..25c2029dfc 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -17,6 +17,7 @@ 
 ;;; Copyright © 2019 Taylan Kammer <taylan.kammer@gmail.com>
 ;;; Copyright © 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 Timothy Sample <samplet@ngyro.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -904,4 +905,34 @@  (define-public guile-zstd
 compression library.")
     (license license:gpl3+)))
 
+(define-public guile-lzma
+  (package
+    (name "guile-lzma")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://files.ngyro.com/guile-lzma/guile-lzma-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "1f7pd3frckpwsi5p0bln4wf8xy41x0szlpy273phjdmjacw69hzb"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("guile" ,guile-3.0)
+       ("guile-bytestructures" ,guile-bytestructures)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("guile" ,guile-3.0)
+       ("xz" ,xz)))
+    (propagated-inputs
+     `(("guile-bytestructures" ,guile-bytestructures)))
+    (home-page "https://ngyro.com/software/guile-lzma.html")
+    (synopsis "Guile bindings for liblzma (XZ)")
+    (description "Guile-LZMA is a Guile wrapper for the liblzma (XZ)
+library.  It exposes an interface similar to other Guile compression
+libraries, like Guile-zlib.")
+    (license license:gpl3+)))
+
 ;;; guile.scm ends here